View Single Post
Old 12-17-03, 03:03 PM   #4
tourettes
Registered User
 
Join Date: Nov 2002
Posts: 31
Send a message via ICQ to tourettes
Default

See, the problem is, whenever I run Quake3 using any sound modules (i810_audio, alsa intel8x0), i get lockups in Quake3 that locks my X-server cause me to Ctrl-Alt-Backspace. This happens constantly, And I can't figure out what is causing it. The only way I can run Quake3 and not get these lockups is if i either turn off the sound all-together, or run it through artsd (using artsdsp -m quake3), which is not acceptable obviously because of the aweful sound lag.

I pass spdif_status=0 to the module because of statements in the release notes for the driver.

Quote:
The "spdif_status" module parameter is used to enable or disable S/PDIF support in the driver. By default S/PDIF is enabled, but can be disabled by setting spdif_status to 0. The driver can only support 48kHz sample rate when S/PDIF is enabled, so disabling it will increase compatability with applications that make assumptions about what sample rates the driver supports.
I have followed the directions step by step on the alsa website for setting up the nforce audio.
__________________
Corey Quilliam
tourettes@linuxhelp.ca

For free Linux technical support, please visit our forums at The Linuxhelp Forums
tourettes is offline   Reply With Quote