View Single Post
Old 09-25-11, 09:45 PM   #17
Wylbur
Registered User
 
Join Date: Sep 2011
Posts: 1
Default Re: Nvidia 9600GT: Xorg process and high CPU usage

I am running (now) a GeForce 8400GS with OpenSuSE 11.4 and Nouveau (Open source Nvidia driver). I had been running the NVidia driver (level I don't have now as I fully uninstalled and deleted it). My CPU is an AMD Athlon 64 X2 Dual Core 4200+ and I have 8GB of RAM. While running a monitor to watch this, memory and swap usage do not seem to change all that much.

Let me confirm some things that have already been posted.

If I let the machine sit here, bootted up and signed on as a user with Firefox and Gnome Sysmonitor running withi top, and come back to it the next day, it is slow. If I allow it to just sit like this for two days, Xorg will be eating so much of one core (as in 100%) that firefox is non-responsive.

Reboot the machine and do some simple work with Open Office writing a document and working with a spreadsheet and Firefox and within 1.5 hours you will notice jerky response. Look at top and there's xorg peaking at over 80%, and one is not really doing anything.

So, it would seem that if this problem is this easy to recreate using OpenSuSE 11.4 with the NVidia driver, but not the Noveau driver, then those who do NVidiea driver work shouldn't have a major big deal with recreating this.

Would running a wallpaper changer (that changes the wall paper every 15 minutes or so) really contribute to this, or actually be the cause? If that is the case, why doesn't it cause the problem under the open source graphics driver?
Wylbur is offline   Reply With Quote