View Single Post
Old 12-19-03, 04:43 PM   #1
snaboofypop
Registered User
 
Join Date: Aug 2003
Posts: 29
Unhappy No screens found in fedora core

Hi. I just updated from RedHat 9 to fedora core. The nvidia drivers were working fine in RH9 (including GLX and twinview), but they don't work in Fedora. I am running kernel 2.6.0 (just like I was in RH). lsmod shows:
nvidia 1708300 0.
I am using the same XF86Config that I was in RH9 (excpet in Fedora I renamed it to XF86Config-4). XFree86.0.log shows that the driver dies at:
II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "glx"
(WW) Warning, couldn't open module glx
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (module does not exist, 0)
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o

(but this is crazy since the driver *is* loaded. It also sits in /lib/modules/2.6.0/kernel/drivers/video
I have already run depmod 2.6.0 after applying the patch and building 4496. Any ideas? Has anyone gotten fedora core running with the accelerated nvidia drivers?
snaboofypop is offline   Reply With Quote