View Single Post
Old 10-13-11, 07:57 PM   #1
shankos
Registered User
 
Join Date: Oct 2011
Posts: 3
Default QuadroNVS280-ubuntu-compix-xserver1.7.6-slow

The problem is my display is rendering very slow. The compiz cube is very laggy when windows are on the screen and even some text scrolling in firefox and moving windows around is slow to render correctly

I originally wanted to use twindisplay but this results in even more rendering slowness so i have dropped back to a single monitor.

I am using compiz windows manager in ubuntu 10 with x server 1.7.6.

I have installed the legacy nvidia NVIDIA-Linux-x86-173.14.31-pkg1.run driver required for this video card quadro NVS 280 pci.

I am not getting errors show up for nvidia in the Xorg.0.log file which i have attached.

glxinfo reports that nvidia is being used

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

I have also included the nvidia bug report.

Below is my xorg.conf

I have tried disabling and changing different options available these ones seems to get the best results I dont think it is much better however then not having any options.
Option "Backingstore"
Option "RenderAccel" "true"
Option "NoLogo" "true"
Option "NvAGP" "1"



Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "extmod"
Load "dbe"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
# HorizSync 30.0 - 110.0
# VertRefresh 50.0 - 150.0
# Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "Backingstore"
Option "RenderAccel" "true"
Option "NoLogo" "true"
Option "NvAGP" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
Attached Files
File Type: gz nvidia-bug-report.log.gz (67.5 KB, 50 views)
File Type: log Xorg.0.log (13.6 KB, 46 views)
shankos is offline   Reply With Quote