View Single Post
Old 10-14-11, 02:26 PM   #1
PranavG189
Registered User
 
Join Date: Oct 2011
Posts: 5
Default slow animations using nvidia prop. driver in KDE 4.7,GNOME 3.2

I'm Experiencing slow and unsmooth animations in KDE 4.7 and GNOME 3.2 using NVIDIA prop. driver.

Some information about my system-:

1)output for lsmod |grep nvidia:

nvidia 10375368 40
i2c_core 21572 2 nvidia,i2c_nforce2

2)output for glxinfo |grep -i “\(direct render\|opengl\)”:

direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 7025 / nForce 630a/PCI/SSE2/3DNOW!
OpenGL version string: 2.1.2 NVIDIA 280.13
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
OpenGL extensions:

3)output for glxgears(about 1min run):

8350 frames in 5.0 seconds = 1669.978 FPS
8373 frames in 5.0 seconds = 1674.491 FPS
8560 frames in 5.0 seconds = 1711.956 FPS
8569 frames in 5.0 seconds = 1713.707 FPS
8566 frames in 5.0 seconds = 1713.158 FPS
8563 frames in 5.0 seconds = 1712.523 FPS
8557 frames in 5.0 seconds = 1711.322 FPS
8562 frames in 5.0 seconds = 1712.258 FPS
8565 frames in 5.0 seconds = 1712.976 FPS
8565 frames in 5.0 seconds = 1712.963 FPS
8557 frames in 5.0 seconds = 1711.249 FPS
8562 frames in 5.0 seconds = 1712.356 FPS
8559 frames in 5.0 seconds = 1711.676 FPS
8548 frames in 5.0 seconds = 1709.466 FPS

Animations in gnome 3.2 are not smooth when-:
1)while minimizing window
2)switching to overview when windows and system tray icons are present.

Also, When Desktop effects are enabled in KDE, they are also not smooth.

I tried sending this as a bug to the linux-nvidia-bugs, but the developers didn't reply me either.

Games such as Urban Terror, Alien Arena Run very good even in high graphics.And I don't know what's the problem with glxgears. The FPS is abnormally very high.If you want I can post a link to the video file in my dropbox account showing the slowness.(I have tried with nouveau. It works fine with both the desktops.The problem is only with NVIDIA prop.)The video link is-:

http://dl.dropbox.com/u/37685009/shell-20111012-1.webm

Is there any settings file for NVIDIA prop. where we can deliberately reduce the FPS?

Please Help Me! I am not able to run KDE or GNOME due to this problem.

If you want more information I will provide it to you.

(By the way I'm Using Arch linux . Every distro I used Had this problem same before, be it fedora, ubuntu or mint. so it's independent of distro.)
PranavG189 is offline   Reply With Quote