View Single Post
Old 12-20-03, 01:14 PM   #1
gaular
Registered User
 
Join Date: Dec 2003
Location: Venezuela
Posts: 1
Default kernel 2.6.0 no compile

Hi

I have the kernel 2.6.0 , I tried to compile the lastest driver and:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Dec 20 14:05:20 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
4496). As part of installing this driver (version: 1.0-4496), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel include path: '/lib/modules/2.6.0/build/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/lib/modules/2.6.0/bui
ld/include'...
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -
DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
L=4496 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -I. -I/li
b/modules/2.6.0/build/include -Wno-cast-qual nv.c
En el fichero in from /lib/modules/2.6.0/build/include/linux/smp.h:17,
from /lib/modules/2.6.0/build/include/linux/sched.h:23,
from /lib/modules/2.6.0/build/include/linux/module.h:10,
from nv-linux.h:28,
from nv.c:14:
/lib/modules/2.6.0/build/include/asm/mpspec.h:8: error: `MAX_MP_BUSSES' unde
clared here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:9: error: `MAX_MP_BUSSES' unde
clared here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:10: error: `MAX_MP_BUSSES' und
eclared here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:12: error: `MAX_MP_BUSSES' und
eclared here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:19: error: `MAX_APICS' undecla
red here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:20: error: `MAX_MP_BUSSES' und
eclared here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:20: error: conflicting types f
or `mp_bus_id_to_type'
/lib/modules/2.6.0/build/include/asm/mpspec.h:8: error: previous declaration
of `mp_bus_id_to_type'
/lib/modules/2.6.0/build/include/asm/mpspec.h:22: error: `MAX_IRQ_SOURCES' u
ndeclared here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:24: error: `MAX_MP_BUSSES' und
eclared here (not in a function)
/lib/modules/2.6.0/build/include/asm/mpspec.h:24: error: conflicting types f
or `mp_bus_id_to_pci_bus'
/lib/modules/2.6.0/build/include/asm/mpspec.h:12: error: previous declaratio
n of `mp_bus_id_to_pci_bus'
/lib/modules/2.6.0/build/include/asm/mpspec.h:54: error: `MAX_APICS' undecla
red here (not in a function)
In file included from /lib/modules/2.6.0/build/include/asm/smp.h:20,
from /lib/modules/2.6.0/build/include/linux/smp.h:17,
from /lib/modules/2.6.0/build/include/linux/sched.h:23,
from /lib/modules/2.6.0/build/include/linux/module.h:10,
from nv-linux.h:28,
from nv.c:14:
/lib/modules/2.6.0/build/include/asm/io_apic.h:120: error: `MAX_IRQ_SOURCES'
undeclared here (not in a function)
/lib/modules/2.6.0/build/include/asm/io_apic.h:120: error: conflicting types
for `mp_irqs'
/lib/modules/2.6.0/build/include/asm/mpspec.h:22: error: previous declaratio
n of `mp_irqs'
En el fichero incluído de /lib/modules/2.6.0/build/include/linux/smp.h:17,
de /lib/modules/2.6.0/build/include/linux/sched.h:23,
de /lib/modules/2.6.0/build/include/linux/module.h:10,
de nv-linux.h:28,
de nv.c:14:
/lib/modules/2.6.0/build/include/asm/smp.h:73:26: mach_apicdef.h: No existe
el fichero o el directorio
In file included from /lib/modules/2.6.0/build/include/linux/smp.h:17,
from /lib/modules/2.6.0/build/include/linux/sched.h:23,
cluído de /lib/modules/2.6.0/build/include/asm/smp.h:18,
from /lib/modules/2.6.0/build/include/linux/module.h:10,
from nv-linux.h:28,
from nv.c:14:
/lib/modules/2.6.0/build/include/asm/smp.h: En la función `hard_smp_processo
r_id':
/lib/modules/2.6.0/build/include/asm/smp.h:77: aviso: implicit declaration o
f function `GET_APIC_ID'
En el fichero incluído de nv.c:14:
nv-linux.h:51:4: #error This driver does not support 2.6.x or newer kernels!
En el fichero incluído de /lib/modules/2.6.0/build/include/linux/irq.h:20,
de /lib/modules/2.6.0/build/include/asm/hardirq.h:6,
de /lib/modules/2.6.0/build/include/linux/interrupt.h:11,
de nv-linux.h:79,
de nv.c:14:
/lib/modules/2.6.0/build/include/asm/irq.h:16:25: irq_vectors.h: No existe e
l fichero o el directorio
In file included from /lib/modules/2.6.0/build/include/asm/hardirq.h:6,
from /lib/modules/2.6.0/build/include/linux/interrupt.h:11,
from nv-linux.h:79,
from nv.c:14:
/lib/modules/2.6.0/build/include/linux/irq.h: En el nivel principal:
/lib/modules/2.6.0/build/include/linux/irq.h:70: error: `NR_IRQS' undeclared
here (not in a function)
In file included from /lib/modules/2.6.0/build/include/linux/irq.h:72,
from /lib/modules/2.6.0/build/include/asm/hardirq.h:6,
from /lib/modules/2.6.0/build/include/linux/interrupt.h:11,
from nv-linux.h:79,
from nv.c:14:
/lib/modules/2.6.0/build/include/asm/hw_irq.h:28: error: `NR_IRQ_VECTORS' un
declared here (not in a function)
/lib/modules/2.6.0/build/include/asm/hw_irq.h:31: error: `NR_IRQS' undeclare
d here (not in a function)
En el fichero incluído de nv.c:14:
nv-linux.h:402:2: #error "Couldn't determine number of arguments expected by
remap_page_range!"
In file included from nv.c:14:
nv-linux.h: En la función `NV_IRQL_IS_RAISED':
nv-linux.h:490: aviso: implicit declaration of function `__save_flags'
nv.c: En la función `nv_kern_vma_open':
nv.c:958: aviso: `MOD_INC_USE_COUNT' is deprecated (declared at /lib/modules
/2.6.0/build/include/linux/module.h:482)
nv.c: En la función `nv_kern_vma_release':
nv.c:992: aviso: `MOD_DEC_USE_COUNT' is deprecated (declared at /lib/modules
/2.6.0/build/include/linux/module.h:494)
nv.c: En la función `nv_kern_open':
nv.c:1189: aviso: al pasar el argumento 2 de `request_irq' de tipo de punter
o incompatible
nv.c:1210: aviso: `MOD_INC_USE_COUNT' is deprecated (declared at /lib/module
s/2.6.0/build/include/linux/module.h:482)
nv.c: En la función `nv_kern_close':
nv.c:1303: aviso: `MOD_DEC_USE_COUNT' is deprecated (declared at /lib/module
s/2.6.0/build/include/linux/module.h:494)
nv.c: En la función `nv_kern_mmap':



Any answer??
gaular is offline   Reply With Quote