View Single Post
Old 10-21-11, 09:01 AM   #1
gonzo_s
Registered User
 
Join Date: Mar 2009
Posts: 58
Default NVidia and recent 3.0.x Kernels

Well, I wrote about it already on this forum. Today I've found out my problem at last:

After compiling the kernel I always delete the sources, install the kernel and reboot into it in order to install NVidia drivers. It worked for me like a charm with all previous kernel versions until now actually (the packages were portable and I could bring them to my work and install them there without issues).

But with 3.0.x kernel branch I cannot compile the driver if I delete the sources prior to it. All I get is the following error:

Quote:
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
But today I decided to give it another try and didn't delete the sources. And... voila! I was able to install the NVidia driver.

The question is: what has changed in the recent kernel ? I'm a bit confused. Is it possible that NVidia driver somehow fails to detect the right path to kernel headers with recent kernels ?

Thank you in advance, NVidia team!
gonzo_s is offline   Reply With Quote