View Single Post
Old 12-22-03, 12:24 AM   #30
quantaman
Registered User
 
Join Date: Dec 2002
Location: Canada
Posts: 17
Default

Quote:
Originally posted by Wolfman [TWP]
Looks like you also have sound issues. I run the full version of UT2K3 and also managed to get it patched to 2555 now. All is running ok here.

This is basically what you should have in your /etc/X11/XF86Config file.

In the Modules section should be the following:

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

At the very end of this file, where they have stuff relating to DRI group (Or something of that nature) I competely removed.

Then of cource setup the video card section like this (It may slightly vary on your system):-

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "MSI"
BoardName "NVIDIA GeForce 4 MX 440"
Option "IgnoreDisplayDevices" "DFP, TV"
Option "NvAGP" "1"
Option "RenderAccel" "1"
Option "DigitalVibrance" "64"
Option "CursorShadow" "1"
EndSection

And that's pretty much it, in relation to the video stuff in XF86Config file.

And in the /etc/modules.conf I have the following two lines relating to video:-

options nvidia NVreg_EnableAGPFW=1 NVreg_EnableAGPSBA=1
alias char-major-195 nvidia

The top line might not be needed, if your card can't use the SBA & FW stuff.

This info is from this system here at work, and it runs UT2K3-Demo without a problem. The system I run at home is basically the same except I run a GF FX5900 Ultra in that system. The configuration is pretty much identical.

Wolf
tried the changes but it made no difference,
ps thanks for all this continuing help
Attached Files
File Type: txt xf86config.txt (3.5 KB, 108 views)
quantaman is offline   Reply With Quote