View Single Post
Old 11-08-11, 09:55 AM   #1
FrozenFox
Registered User
 
Join Date: Nov 2011
Posts: 8
Default [Fixed] Drivers after 280.13 break transparency in TF2.

Arch Linux x86_64, up to date. Team Fortress 2 in wine has issues with transparency when using a newer nvidia driver. Wine version and kernel version are unrelated, as they are kept stable throughout reproducing this bug with changing only Xorg and Nvidia drivers. The same issue did occur in an old version of wine too in the same way, but this is running the latest (1.3.32).

Visual guide to what is wrong (transparency is very bright like it is lit up.. pretty clear difference in the pictures below):

http://img.photobucket.com/albums/v4...nFoxZ/good.jpg Fine.
http://img.photobucket.com/albums/v4.../notsogood.jpg Broken.
http://img.photobucket.com/albums/v4...xZ/perfect.jpg Fine.
http://img.photobucket.com/albums/v4...notsogood2.jpg Broken cloak + water.

Steps to reproduce for me:

1. Install Xorg-server 1.10.4 and Nvidia 280.13.
2. Go to map ctf_doublecross and go downstairs where the water is as a spy.
3. Notice the water is fine, and so is cloak with right click.
4. Fire the revolver at least once, then cloak again.. no problems.

1. Install Xorg-server 1.11.2 prerelease and Nvidia 285.05.
2. Go to map ctf_doublecross and go downstairs where the water is as a spy.
3. Notice the water is very bright for some reason. Cloak works fine though.
4. Fire with the revolver at least once, then cloak. The cloaking is messed up now too, and very bright.

Here are combinations I have tried.. note that I rebooted after installing each combination just to be absolutely certain they applied fully:

1. Xorg-server 1.10.4 + Nvidia 280.13 = No problems
2. Xorg-server 1.10.4 + Nvidia 285.05 = Messed up
3. Xorg-server 1.11.2 prerelease + Nvidia 280.13 (w/ ignoreABI) = No problems
4. Xorg-server 1.11.2 prerelease + Nvidia 285.05 = Messed up

EDIT: They say the simplest solution is usually the best one. For everyone else experiencing this bug running Arch, use Arch's xorg packages. Then, download and edit Arch's nvidia, nvidia-utils, lib32-nvidia-utils, and opencl-nvidia [part of nvidia-utils] PKGBUILDs to match the nvidia "long lived" (275.36 at this moment) packages -- you should only need to change the pkgver and md5sum lines. Build and install those. If somebody needs, I can send them the pkgbuilds or built packages. Make sure to block them from being upgraded further via IgnorePkg in /etc/pacman.conf .

----------------------
As a side note, combination #3 worked just fine the first reboot, but after rebooting a second time, steam wouldn't even start with the following error. It doesn't really matter though, I prefer doing it the right way anyway and just sticking to combination #1. I have reproduced that weird little quirk several times. Ultimately though, I doubt this is important, and probably has something to do with ignoreABI and isnt particularly related to this bug.

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 135 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x2b
Serial number of failed request: 1396
Current serial number in output stream: 1397
Attached Files
File Type: gz nvidia-bug-report.log.gz (66.1 KB, 103 views)

Last edited by FrozenFox; 01-05-12 at 11:01 PM.
FrozenFox is offline   Reply With Quote