View Single Post
Old 11-22-11, 08:27 PM   #387
jlinkels
Registered User
 
Join Date: Nov 2011
Posts: 3
Default Re: VDPAU testing tool

Hi,

Thanks for looking into this.

Hardware:
AMD Athlon(TM) XP 1800+
NVIDIA GPU GeForce 8400GS (GT218) at PCI:2:0:0 (GPU-0)
512 MB system RAM
NVIDIA Gefore 8400 GS also contains 512 MB RAM

Software:
Debian Stable with vdpau packages from Sid
libvdpau1 Versions: 0.4.1-3
vdpau-va-driver Versions: 0.7.3-1
NIVIDIA proprietary driver 285.05.09
xorg-server 2:1.7.7-13

vainfo:
Code:
glinkels@katrien-pc:/mnt/homeserv/data/movies/scoobydoo2$ vainfo
libva: libva version 0.32.0
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.32
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.3
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG4Simple            : VAEntrypointVLD
      VAProfileMPEG4AdvancedSimple    : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
glinkels@katrien-pc:/mnt/homeserv/data/movies/scoobydoo2$
vlc 1.1.12
Started from the command line:
Code:
glinkels@katrien-pc:/mnt/homeserv/data/movies/scoobydoo2$ vlc sem-scoobytwo.720p.mkv
VLC media player 1.1.3 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x86a98fc] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
Blocked: call to setlocale(6, "")
 m_el[mi_level] == NULL
 arrrrrrrrrrrrrg Up cannot escape itself
 m_el[mi_level] == NULL
 arrrrrrrrrrrrrg Up cannot escape itself
[0x895bb9c] dts decoder: DTS channels:6 samplerate:48000 bitrate:1536000
libva: libva version 0.32.0
Xlib:  extension "XFree86-DRI" missing on display ":0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/nvidia_drv_video.so
[0x8964fdc] pulse audio output error: cannot connect to server: Connection refused
libva: va_openDriver() returns 0
[0x88d2044] avcodec decoder: Using VA API version 0.32 for hardware decoding.
>>>>>>>>>>> movie is playing here, no more messages >>>>>>>>>>>>>>>>>>
~
mplayer, started from the command line:
Code:
mplayer -vo vdpau  sem-scoobytwo.720p.mkv
MPlayer 1.0rc3-4.4.4 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing sem-scoobytwo.720p.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS), -aid 0, -alang eng
[mkv] Track ID 3: subtitles (S_TEXT/UTF8), -sid 0, -slang eng
[mkv] Track ID 4: subtitles (S_TEXT/UTF8), -sid 1, -slang spa
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x720  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC1D0p' failed (-2): No such file or directory
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa'
[AO SDL] Samplerate: 48000Hz Channels: Stereo Format s16le
[AO SDL] using aalib audio driver.
[AO SDL] Unable to open audio: No available audio device
Failed to initialize audio driver 'sdl:aalib'
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1280x720 => 1280x720 Planar YV12
V:   8.8   0/  0 70% 87%  0.0% 0 0
nvidia-bug-report: http://mail.linkels.net/~jlinkels/li...-report.log.gz
Xorg.0.log: http://mail.linkels.net/~jlinkels/links/Xorg.0.log

jlinkels
jlinkels is offline   Reply With Quote