View Single Post
Old 12-24-03, 11:32 AM   #1
Tarken
Registered User
 
Join Date: Sep 2002
Location: Tempe, AZ
Posts: 4
Send a message via ICQ to Tarken Send a message via AIM to Tarken
Default Success with 5328 on Fedora Core 1

Okay, so I previously posted up that I was having many of the same issues as other people in here with the newly released drivers, and after much rebooting and cursing I finally got them to work properly.

Here's what I did:

* First, completely uninstall any previous drivers to give a fresh start:
./NVIDIA-Linux-x86-1.0-5328-pkg1.run --uninstall

* Second, install the new one, forcing it to compile a new kernel interface:
CC=gcc32 ./NVIDIA-Linux-x86-1.0-5328-pkg1.run -n

Note that in order for this to work, you need to have the "gcc32" package installed. This is what the Fedora Core 1 kernel was built with, as opposed to the default FC1 compiler, gcc 3.3.

* Third, REMOVE the "NvAGP" option from /etc/X11/XF86Config


I suspect that the gcc version problem is actually what's causing the kernel OOPS for everybody. With previous driver packages, they simply would not load unless you specified the compiler of gcc32. However, with 5328, the module will actually load but with errors.

After that is all done, everything should be working great. I'm now getting around 2500 fps in glxgears as opposed to 5.
Tarken is offline   Reply With Quote