View Single Post
Old 12-15-11, 01:10 AM   #1
anketell
Registered User
 
Join Date: Dec 2011
Posts: 12
Default X Server fails to start Fedora 16 GT330M

Having just upgraded to Fedora 16, I am having trouble loading an nvidia driver. I have tried the standard package version 290.10 and have compiled several earlier drivers to no avail. All drivers report the following:

[ 24.810136] NVRM: failed to copy vbios to system memory.
[ 24.811605] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 24.811617] NVRM: rm_init_adapter(0) failed
[ 25.018686] NVRM: failed to copy vbios to system memory.
[ 25.020173] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.020185] NVRM: rm_init_adapter(0) failed
[ 25.209577] NVRM: failed to copy vbios to system memory.
[ 25.211061] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.211073] NVRM: rm_init_adapter(0) failed
[ 25.409101] NVRM: failed to copy vbios to system memory.
[ 25.410620] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.410632] NVRM: rm_init_adapter(0) failed
[ 25.601878] NVRM: failed to copy vbios to system memory.
[ 25.604997] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.605037] NVRM: rm_init_adapter(0) failed
[ 25.781421] NVRM: failed to copy vbios to system memory.
[ 25.782853] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.782864] NVRM: rm_init_adapter(0) failed

Previously, under Fedora 14, I needed to recompile driver 260.* as later drivers (packaged or otherwise) would not work. Unfortunately the 260.* driver will not compile against the 3.1.4 kernel of Fedora 16.

I have attached to output of nvidia-bug-report.sh

When run it reported the following three times:

NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).

Any assistance in resolving this issue would be greatly appreciated.
Attached Files
File Type: gz nvidia-bug-report.log.gz (79.8 KB, 72 views)
anketell is offline   Reply With Quote