View Single Post
Old 12-21-11, 08:43 AM   #124
uOpt
FreeBSD cheering section
 
uOpt's Avatar
 
Join Date: Nov 2004
Location: Boston, MA, USA
Posts: 609
Default Re: Nvidia support for Xen

I'm still having no luck here. I now have kernel 3.1.5 and I'm still segfaulting with the 285.05.09 drivers. It runs fine when booting the same kernel not inside Xen.

This happens both in Xorg server 1.7.7 and Xorg 7.1.1.

(II) Dec 18 17:56:37 NVIDIA(0): Setting mode "2560x1600"
(WW) Dec 18 17:56:40 NVIDIA(0): WAIT (0, 1, 0x8000, 0x000000bc, 0x000000bc)
(EE) Dec 18 17:56:40 NVIDIA(0): Error setting DVC.
(WW) Dec 18 17:56:43 NVIDIA(0): WAIT (0, 6, 0x8000, 0x00001274, 0x00001274)

Backtrace:
0: X (xorg_backtrace+0x28) [0x4acd58]
1: X (0x400000+0x61a09) [0x461a09]
2: /lib/libpthread.so.0 (0x7f2a695f2000+0xef60) [0x7f2a69600f60]
3: X (dixAllocatePrivate+0x78) [0x450c08]
4: X (dixLookupPrivate+0x35) [0x450de5]
5: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f2a62f85000+0x36df37) [0x7f2a632f2f37]
6: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f2a62f85000+0xc1585) [0x7f2a63046585]
7: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f2a62f85000+0xc1c80) [0x7f2a63046c80]
8: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f2a62f85000+0x82c5e) [0x7f2a63007c5e]
9: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f2a62f85000+0xf0d2e) [0x7f2a63075d2e]
10: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f2a62f85000+0xb7460) [0x7f2a6303c460]
11: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7f2a62f85000+0x33fa48) [0x7f2a632c4a48]
12: X (AddScreen+0x1d4) [0x442d54]
13: X (InitOutput+0x7af) [0x46808f]
14: X (0x400000+0x25a8a) [0x425a8a]
15: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7f2a680f6c4d]
16: X (0x400000+0x257e9) [0x4257e9]
Segmentation fault at address 0x290

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting
__________________

My Unix benchmark results
uOpt is offline   Reply With Quote