View Single Post
Old 02-14-12, 09:55 AM   #16
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by MadCatX View Post
Regarding the mplayer issues, I believe that at least some of those are caused by mplayer2. I've been experimenting with mplayer2 on and off for quite some time and I've always reverted back to vanilla mplayer because of all sorts of weird issues including the green flashing.
Just removed mplayer2/libav and installed mplayer/ffmpeg. The problem is still there. Not the green flash, I mean the real problem.

Quote:
Possible freezes when toggling between FS<->window are caused by KWin unredirecting. You can either disable unredirecting for fullscreen apps (System settings->Desktop effects->Advanced)
That kills 3D performance of games. Fullscreen really needs to be unredirected. Even Windows Aero does that.

Quote:
or create a rule in KWin to disable compositing when SMPlayer is running.
That kills the desktop experience.

The only thing that can be done is disabling VDPAU. Which in turn means the problem really needs to be fixed.

Quote:
Even though the decoding is done on CPU, the video is still being drawn using VDPAU. Since your problems go away when you switch compositing off, it's probably a drawing problems.
There's no reason to use VDPAU then. Xv is much better.

Quote:
I'm not having any problems with Flash on 9800M GTS, you can also disable the HW decoding altogether by adding "EnableLinuxHWVideoDecode=0" to /etc/adobe/mms.cfg. My over 3 years old laptop can handle 1080p Flash videos without VDPAU with ease.
The real problem is that without accelerated rendering, fullscreen Flash video is tearing very badly. Accelerated decoding doesn't matter much to me anyway, since the machine has a 2500K CPU. The problem is the tearing in fullscreen.

NVidia, please please try and fix VDPAU+composite
RealNC is offline   Reply With Quote