View Single Post
Old 01-01-04, 05:29 PM   #1
Nowhere_Man
Registered User
 
Join Date: Oct 2003
Posts: 14
Default Mandrake 9.2 and NVidia 1.0-5328

Ok, Im using Mandrake 9.2 with 2.4.22-10mdksmp, a Geforce4 MX 440 (64MB), ECS motherboard (L4VXA2) w/P4X400 North and VT8233A southbridge. 512 MB DDR. This is a clean install and works perfectly with the nv driver.

When I ran the Nvidia installer everything installed fine and the kernel moduals load fine. When I type startx the screen goes blank and seems to try to display the Nvidia splashscreen but stays black. There is a video signal being sent to the monitor because the power light stays green. ALT-Ctrl-Bcksp does not work. Neither does Alt-Ctrl-+/-. It seems from looking at the /var/log/XFree86 log that it might be something with the display but I'm not sure at this point. I am Attaching the log file, and my XF86 config file. Any help would be appreciated. Let me know if you need more info. I know the XFconfig file lists nv driver. That is so I could get here to post. I did change the nv to nvidia.

Thanks,
Charlie

XF86config-4

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1280x1024 @ 60 Hz"
HorizSync 30-70
VertRefresh 50-120

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nv"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection
Attached Files
File Type: log xfree86.0.log (23.2 KB, 164 views)
Nowhere_Man is offline   Reply With Quote