View Single Post
Old 01-02-04, 11:34 AM   #5
--- Zest ---
Registered User
 
Join Date: Dec 2003
Location: Netherlands
Posts: 7
Default

Here's what to do for Kernel versions 2.4.xxx
(For versions 2.6.xxx you need the other driver from http://www.sh.nu/download/nvidia)

1) install the Kernel sources. Usually this means
installing the 'kernel-source' package with YaST2. Update it - if not
already done - via YaST2 Online Update (YOU).

2) Download the ALTERNATIVE nvidia installer for 1.0-5328.

http://www.sh.nu/download/nvidia/lin...-5328-pkg0.run

from http://www.sh.nu/download/nvidia/linux-2.4/

3) Boot linux to the VGA console. You can do this in 2 ways:

a) edit the etc/inittab file and change the line
id:5:initdefault:
to
id:3:initdefault:
Note that this is a definite change until you edit the file back to it's original state.

The easy way is to start the console and type 'init 3'

4) install the driver:

Change to the dir with the driver and run:

sh NVIDIA-Linux-x86-1.0-5328-pkg0.run

The .run file is a self-extracting archive. When the .run file is executed,
it extracts the contents of the archive, and runs the contained 'nvidia-installer'
utility, which will walk you through installation of the NVIDIA driver.

3) Configure XFree86 with

sax2 -m 0=nvidia (0 is a digit, not a letter!)

NOTE: There is no need to try to enable 3D support. It's already enabled,
when the nvidia driver is running. Ignore the misleading error message,
that 3D support can't be enabled. This problem will be fixed with
SuSE > 9.0 and is related to the latest nvidia driver release.

5) Edit your XF86config file:

This is located here: /etc/X11/XF86Config

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries. After you restart X,
you should be able to run any OpenGL application and it will automatically use the new NVIDIA libraries.

4) boot back into x, by typing

init 5


This should work if I haven't forgotten anything :-)
Good Luck!
--- Zest --- is offline   Reply With Quote