View Single Post
Old 03-19-12, 12:08 PM   #6
PhoenixUT
Registered User
 
Join Date: Oct 2004
Posts: 11
Default Re: Random video hangs after upgrading from 290.10 to 295.9 and 295.17

Still suffering random VDPAU hangs in the kernel ISR when using the 295.xx series drivers. Any insight woudl be greatly appreciated. Please request any additional information that may be helpful. The only thing that the hangs seem to be related to is seeking while watching video in MythTV. When a hang occurs the video freezes before jumping to the new location (after the seek).

Code:
irq 50: nobody cared (try booting with the "irqpoll" option)
Pid: 11019, comm: mythcommflag Tainted: P            3.1.1 #5
Call Trace:
 [<c1065fe1>] ? __report_bad_irq+0x21/0xc0
 [<c106619e>] ? note_interrupt+0x11e/0x1d0
 [<f604ebff>] ? nv_kern_isr+0x2f/0x70 [nvidia]
 [<c1064626>] ? handle_irq_event_percpu+0x66/0x140
 [<c1067d52>] ? irq_move_masked_irq+0x82/0xb0
 [<c1066840>] ? irq_check_poll+0x20/0x20
 [<c106472c>] ? handle_irq_event+0x2c/0x50
 [<c1066840>] ? irq_check_poll+0x20/0x20
 [<c1066894>] ? handle_edge_irq+0x54/0xd0
 <IRQ>  [<c1003ead>] ? do_IRQ+0x3d/0xc0
 [<c1037091>] ? irq_exit+0x31/0xa0
 [<c1019e11>] ? smp_apic_timer_interrupt+0x51/0x90
 [<c1037270>] ? irq_enter+0x60/0x60
 [<c1277e69>] ? common_interrupt+0x29/0x30
 [<c1037270>] ? irq_enter+0x60/0x60
 [<c10372b3>] ? __do_softirq+0x43/0xf0
 [<c1037270>] ? irq_enter+0x60/0x60
 <IRQ>  [<c10370ce>] ? irq_exit+0x6e/0xa0
 [<c1003eb6>] ? do_IRQ+0x46/0xc0
 [<c1037091>] ? irq_exit+0x31/0xa0
 [<c1019e11>] ? smp_apic_timer_interrupt+0x51/0x90
 [<c1277e69>] ? common_interrupt+0x29/0x30
handlers:
[<f604ebd0>] nv_kern_isr
Disabling IRQ #50
NVRM: Xid (0000:07:00): 16, Head 00000000 Count 011fcce6
nvidia 0000:07:00.0: PCI INT A disabled
PhoenixUT is offline   Reply With Quote