View Single Post
Old 03-31-12, 12:34 AM   #10
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Bug in installation skript of nvidia-driver-295.33 for install with kernel 3.3

Quote:
Originally Posted by jdmcdaniel3 View Post
So, if you do a list of commands, the --apply-patch it is not there. I did not get the installer to accept the patch file when I try the command:

Code:
sh ./NVIDIA-Linux-x86_64-295.33.run --apply-patch NVIDIA-295.33.patch
I got the following error message:

Code:
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: NVIDIA-Linux-x86-295.33/kernel/conftest.sh
|===================================================================
|--- NVIDIA-Linux-x86-295.33.orig/kernel/conftest.sh
|+++ NVIDIA-Linux-x86-295.33/kernel/conftest.sh
Now if you use this text file with the patch command it works fine, but you have to extract all of the files from the nVIDIA archive into separate files. How can you use this valid patch file to patch an internal file of the nVIDIA driver and still have an installable all in one single file, just like the original? First off, I appreciate your help, but need exact instructions from someone that actually made it work.

Thank You,
The patch needed a small edit

http://leigh123linux.fedorapeople.or..._3.3_err.patch


Code:
curl http://leigh123linux.fedorapeople.org/pub/patches/nvidia_295_33_for_3.3_err.patch -o nvidia_295_33_for_3.3_err.patch
./NVIDIA-Linux-x86_64-295.33.run --apply-patch nvidia_295_33_for_3.3_err.patch
__________________
leigh123linux
leigh123linux is offline   Reply With Quote