View Single Post
Old 04-03-12, 05:11 AM   #1
eskuai
Registered User
 
Join Date: Aug 2007
Posts: 35
Default nvidia 295.33 .. random freeze ... black screen

Hello,

I got a random totally freeze my system. No keyboard, no mouse and after a seconds, black screen !

My system is a fedora 16, 3.3.0-8 32 bits ... nvidia 295.33 -- hw nvidia gt 240
and X.Org X Server 1.11.4

Xorg.log shows sometimes :=

3242.400] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[ 3242.400]
Backtrace:
[ 3242.400] 0: /usr/bin/X (xorg_backtrace+0x3c) [0x80a86ac]
[ 3242.400] 1: /usr/bin/X (mieqEnqueue+0x175) [0x81ac2f5]
[ 3242.400] 2: /usr/bin/X (0x8048000+0x42892) [0x808a892]
[ 3242.400] 3: /usr/bin/X (xf86PostMotionEventM+0xf2) [0x80dbbe2]
[ 3242.400] 4: /usr/lib/xorg/modules/input/evdev_drv.so (0xb437f000+0x343e) [0xb438243e]
[ 3242.400] 5: /usr/lib/xorg/modules/input/evdev_drv.so (0xb437f000+0x492f) [0xb438392f]
[ 3242.400] 6: /usr/bin/X (0x8048000+0x7e600) [0x80c6600]
[ 3242.400] 7: /usr/bin/X (0x8048000+0xa50cb) [0x80ed0cb]
[ 3242.400] 8: (vdso) (__kernel_sigreturn+0x0) [0xb77cb400]
[ 3242.400] 9: (vdso) (__kernel_vsyscall+0x10) [0xb77cb424]
[ 3242.400] 10: /lib/libc.so.6 (__gettimeofday+0x16) [0xb73d92d6]
[ 3242.400] 11: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0xb4978000+0x62a7d) [0xb49daa7d]
[ 3242.769] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0xdfff2fff, 0x00005d5c)
[ 3249.769] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0xdfff2fff, 0x00005d5c)
[ 3249.769]
Backtrace:
[ 3249.769] 0: /usr/bin/X (xorg_backtrace+0x3c) [0x80a86ac]
[ 3249.770] 1: /usr/bin/X (0x8048000+0x654d6) [0x80ad4d6]
[ 3249.770] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb77cb40c]
[ 3249.770] 3: /lib/libc.so.6 (0xb7330000+0x1441b8) [0xb74741b8]
[ 3249.770] 4: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0xb4978000+0xd8bc8) [0xb4a50bc8]
[ 3249.770] Segmentation fault at address 0xb50fd000
[ 3249.770]
Fatal server error:
[ 3249.770] Caught signal 11 (Segmentation fault). Server aborting
[ 3249.770]
[ 3249.770]

is it an xorg bug o nvidia bug?

any clues?

thank you




Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "yes"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "es"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS" "False"

EndSection

Section "Device"

# Option "DamageEvents" "1"
# Option "PixmapCacheSize" "900000"
# Option "OnDemandVBlankInterrupts" "True"
# Option "AddARGBGLXVisuals" "True"
# Option "DisableGLXRootClipping" "True"
# Option "RegistryDwords" "PowerMizerEnable=0x1;PowerMizerLevel=0x1;PowerMiz erDefaultAC=0x1"
# Option "AllowSHMPixmaps" "0"
# Option "PixmapCacheSize" "1000000"
Option "HDMIAudio" "disable"
# Option "UseEDID" "False"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "true"
# Option "Coolbits" "1"
# Option "RenderAccel" "False"
# Option "UseEvents" "False"

# Option "AddARGBVisuals" "True"
# Option "RenderAccel" "1"
# Option "AllowGLXWithComposite" "1"
# Option "NoRenderExtension" "0"
# Option "XAANoOffscreenPixmaps" "1"
# Option "TripleBuffer" "true"

# Option "TripleBuffer" "1"
# Option "RegistryDwords" "PowerMizerLevelAC=0x3"
# Option "DPMS" "true"
# Option "AllowGLXWithComposite" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"

# Option "RENDER" "True"
# Option "Composite" "True"
# Option "DAMAGE" "True"
EndSection
eskuai is offline   Reply With Quote