View Single Post
Old 04-03-12, 07:51 AM   #3
apriori
Registered User
 
Join Date: Nov 2008
Posts: 22
Default Re: X crashes systematically at startup (Ubuntu 11.10, 8800M GTX/G92M)

Hey man, let me add some stuff I tried on my Clevo 570RU (with an 8800 M GTX) which don't seem to help either.
  1. Deactivate acpi all together - in that scenario the card will "fall of the bus" 28 secs after the last call to acpi, which failed
  2. Code:
    ACPI Warning: For \_SB_.PCI0.PEGP.VGA_.MXMS: Excess arguments - needs 1, found 2 (20110623/nspredef-326)
    in normal mode (full apci with WMI): Same as in 1. but it needs 58 - 60 secs for it. Why on earth that difference? No idea.
  3. Completely blacklisting or even uninstalling nouveau - doesn't help at all (the module nouveau wasn't loaded when the nvidia driver were used anyway) + "nouveau.modeset=0" (which is mandatory when using nvidia binary drivers)
  4. Fix the DSDT - I had 2 errors and 3 warnings in it. The errors were minor (invalid parameter window lengths) so I could fix those easily. However, I can't do anything about the earlier mentioned excess arguments problem, because I don't know enough about that stuff. I doubt that these two calls are the cause of this misbehavior, though, because completely deactiving acpi didn't help either.
  5. Upgrade the BIOS to an unlocked variant for more options (warning: of course out of vendor warranty) - Version 10.13aSL, KBC/EC 1.00.10

    5.1 Deactivate ASPM for the PCIe ports - no change whatsoever
    5.2 Deactivate processor power management - (I had to do that with kernel parameter processor.max_cstate=0 anyway, otherwise the machine would always stall after some time independant of nvidia drivers)
  6. Upgrade the video cards BIOS to version 69.92.40.18 - no change
    Other tried versions: 69.23.00.12 - no change either

Several other "solutions" (none of them works for me) floating around which didn't help:
  1. Using persistance mode as fast as possible on bootup using nvidia-smi
  2. Changing the PCIe port - funny stuff, how shall I do that on a nootebook?

So far the only workaround which is working is - guess what: Reverting to ancient versions of the nvidia driver. Latest working driver is 270.41.19, which of course comes with the implication, that you're stuck with a 2.6 kernel and Xorg 1.10. It's a (excuse me) pain in the ass to actually revert most distros to such old versions of the respective packages. So far every following nvidia driver did not work.

Since this is not my first post about this issue, and there are several others who have the same problem, it would be nice if NVIDIA would actually say a word about this or how we could assist in the solution. This "bug" (and I think it is a bug, because the card works flawlessly under windows) now is VERY old and renders my card useless on linux (I need the performance for graphics dev).

One other thing though, if you went to all the trouble to revert to these ancient versions, the funny thing is, you can even get OpenCL working with it, using the respective lib of the newest drivers. Definetly not an intended feature, I guess, but it works.

EDIT: I will attach the bugreport tar.gz/more logs later this day

Regards

apriori
apriori is offline   Reply With Quote