View Single Post
Old 05-05-12, 04:42 PM   #4
jcdole
Registered User
 
Join Date: May 2011
Posts: 11
Default Re: Cannot set fan speed below 55% on 295.40 drivers. Previously worked.

/etc/X11/xorg.conf.d/50-device.conf have to be modified.

Code:
Section "Device"
#		Identifier "Default Device"
    Identifier  "Video Card"

#		Driver "radeon"
    Driver    "nvidia"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

    Option    "Coolbits" "5"

EndSection
Have removed /etc/X11/xorg.conf.

Command are accepted :

Code:
linux-srv:/local/zypper_install # /usr/bin/nvidia-settings -t --query [fan:0]/GPUCurrentFanSpeed 
53
Code:
linux-srv:/local/zypper_install # nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=90"

  Attribute 'GPUFanControlState' (linux-srv:0[gpu:0]) assigned value 1.

  Attribute 'GPUCurrentFanSpeed' (linux-srv:0[fan:0]) assigned value 90.
Code:
linux-srv:/local/zypper_install # /usr/bin/nvidia-settings -t --query [fan:0]/GPUCurrentFanSpeed 
90
Code:
linux-srv:/local/zypper_install # nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=30"

  Attribute 'GPUFanControlState' (linux-srv:0[gpu:0]) assigned value 1.

  Attribute 'GPUCurrentFanSpeed' (linux-srv:0[fan:0]) assigned value 30.
Code:
linux-srv:/local/zypper_install # /usr/bin/nvidia-settings -t --query [fan:0]/GPUCurrentFanSpeed 
30
__________________
Thank you for helping. JCD
_______________
SAMBA-LDAP PDC server 12.1--qosmio x500 win XP & desktop (12.1>)11.4 -- KDE -- acer aspire 7736g win 7 pro - scan EPSON V500 - Brthr HL2150N - Samsung CLP-325W
jcdole is offline   Reply With Quote