View Single Post
Old 05-18-12, 09:35 PM   #1
Ferianto85
Registered User
 
Join Date: May 2012
Posts: 1
Unhappy Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5

Dear All,

I just tried to install NVIDIA driver for TESLA M2070-Q in RHEL5. I have downloaded the driver for it in nvidia download page (driver version 295.53).
Installing the driver using command:
# sh NVDIA-Linux-X86_64xxx.run

I have clarified that the driver has been installed properly:

# nvidia-installer -i

[root@tomcat log]# nvidia-installer -i

Welcome to the NVIDIA Software Installer for Unix/Linux


The currently installed driver is: 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (version: 295.49).


I read from IBM website (because NVIDIA Tesla M2070Q is attached into IBM Blade HS22), that the usual monitor can not be used to display screen using NVIDIA Tesla, so I installed NX Client no machine to load the user`s screen.

Loading user`s screen is success via NX Client, but while trying to configure NVIDIA Xserver settings, it gave me error message on screen
# nvidia-settings

akan muncul output "You Do Not Appear using NVIDIA X Driver"


I tried for gooling the solution, and I have tried to edit the xorg.conf file (based the information that I got from internet).
I have tried running command :

# nvidia-xconfig


[root@tomcat log]# lspci -vvv|egrep -i "3D controller|nvidia"
19:00.0 VGA compatible controller: nVidia Corporation GF100 [M2070Q] (rev a3) (prog-if 00 [VGA controller])
Subsystem: nVidia Corporation Device 084d
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nvidia
19:00.1 Audio device: nVidia Corporation GF100 High Definition Audio Controller (rev a1)
Subsystem: nVidia Corporation Device 084d
[root@tomcat log]#


Here is I sent the Xorg.conf file :


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 295.49 (buildmeister@swio-display-x86-rhel47-07.nvidia.com) Tue May 1 00:54:24 PDT 2012

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib64/xorg/modules"
FontPath "unix/:7100"
FontPath "built-ins"
EndSection

Section "Module"
Load "xtrap"
Load "extmod"
Load "dbe"
Load "glx"
# Load "vnc"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
# Option "PreferredMode" "1280x1024"
# Option "UseEdidFreqs" "1"
# Option "ReducedBlanking"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Tesla M2070-Q"
Option "RenderAccel" "True"
Option "UseDisplayDevice" "DFP"
Option "ConnectedMonitor" "DFP-0"
BusID "PCI:25:0:0"
# Option "NoLogo" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Modes "1280x1024" "1024x768"
Depth 24
EndSubSection
EndSection

Can anyone give me a solution, please? I have tried looking for solution on the internet. There are many case like this in the internet, but while trying to implement the solution, it still failed.

Please help, me...please...

Thank you

regards,

--Feri---
Attached Files
File Type: log Xorg.0 log messages.log (28.8 KB, 157 views)
File Type: txt dmesg.txt (34.1 KB, 251 views)
Ferianto85 is offline   Reply With Quote