View Single Post
Old 05-26-12, 07:41 PM   #1
joerg.sigle
Registered User
 
Join Date: Aug 2006
Posts: 16
Default 96.43.20 does still not support new X.Org ABI 11 - will an update be procuded?

Hello nvidia team,

after an apt-get update; apt-get dist-upgrade on Debian Wheezy/Sid several weeks ago, my trusted old server lost X11 on its nVidia 440 MX graphics card.

I already installed the latest available driver for this legacy card - which is apparently still 96.43.20. Before attempting to downgrade to an earlier version of xorg, I was wondering whether (when?) you might release some updated version 96.43.21 of your driver. Apparently, the same problem hits other people as well.

Here's the output from starting xorg after the upgrade:

mymachine:~# startx

xserverrc: Starte X-Server für 110 dpi, dpms und mit aktiviertem TCP-Protokoll js

X.Org X Server 1.11.4
Release Date: 2012-01-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 i686 Debian
Current Operating System: Linux mymachine 3.2.11-P3SMP #1 SMP Fri Mar 16 02:12:48 CET 2012 i686
Kernel command line: [...]
Build Date: 05 March 2012 04:16:09AM
xorg-server 2:1.11.4-1 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.24.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May 27 01:38:15 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
================ WARNING WARNING WARNING WARNING ================
This server has a video driver ABI version of 11.0 that is not
supported by this NVIDIA driver. Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
================================================== ===============
(EE) NVIDIA: Use the -ignoreABI option to override this check.
(EE) Failed to load module "nvidia" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.

Thanks a lot in advance for your reply, Joerg
joerg.sigle is offline   Reply With Quote