View Single Post
Old 06-22-12, 01:08 PM   #1
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Retina Macbook Pro

Anyone getting the drivers to work on this? For now I am trying to get it working with no switching between the onboard intel and nvidia.

When starting X I get:

Code:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(==) Jun 22 04:00:03 NVIDIA(0): Using HW cursor
(==) Jun 22 04:00:03 NVIDIA(0): Video key set to default value of 0x101fe
(==) Jun 22 04:00:03 NVIDIA(0): Not mapping the primary surface by default.
(**) Jun 22 04:00:03 NVIDIA(0): Enabling 2D acceleration
(EE) Jun 22 04:00:03 NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
(EE) Jun 22 04:00:03 NVIDIA(0):     check your system's kernel log for additional error
(EE) Jun 22 04:00:03 NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
(EE) Jun 22 04:00:03 NVIDIA(0):     README for additional information.
(EE) Jun 22 04:00:03 NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) Jun 22 04:00:03 NVIDIA(0): Failing initialization of X screen 0
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.
In dmesg I get:

Code:
nvidia 0000:01:00.0: irq 47 for MSI/MSI-X
NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:858)
NVRM: rm_init_adapter(0) failed
Suggestions?
Xevious is offline   Reply With Quote