View Single Post
Old 06-26-12, 06:09 AM   #1
ExecutorElassus
Registered User
 
Join Date: Jun 2006
Posts: 8
Default 3xx drivers causing EQ overflow

So, I'm running gentoo linux for amd64, and recently (last week) upgraded to the 3xx driver.

I'd thought the problems I was having were with flash, so I removed adobe flash. But I still have the problems, any time I ran any sort of video playback. This is what shows up in my Xorg.log.0 file:

Code:
[ 86940.412] (WW) NVIDIA(0): WAIT (0, 6, 0x8000, 0x00004908, 0x00004908) 
[ 86943.058] [mi] EQ overflowing.  Additional events will be discarded until existing events are processed. 
[ 86943.058] 
[ 86943.058] Backtrace: 
[ 86943.234] 0: /usr/bin/X (xorg_backtrace+0x36) [0x5684c6] 
[ 86943.234] 1: /usr/bin/X (mieqEnqueue+0x273) [0x549563] 
[ 86943.234] 2: /usr/bin/X (0x400000+0x49a8d) [0x449a8d] 
[ 86943.234] 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f14819dd000+0x60f0) [0x7f14819e30f0] 
[ 86943.234] 4: /usr/bin/X (0x400000+0x711c7) [0x4711c7] 
[ 86943.234] 5: /usr/bin/X (0x400000+0x9583a) [0x49583a] 
[ 86943.234] 6: /lib64/libc.so.6 (0x7f14873c3000+0x35620) [0x7f14873f8620] 
[ 86943.234] 7: linux-vdso.so.1 (0x7fff46889000+0x607) [0x7fff46889607] 
[ 86943.234] 8: linux-vdso.so.1 (__vdso_gettimeofday+0x115) [0x7fff468899e5] 
[ 86943.235] 9: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f1482528000+0x883a5) [0x7f14825b03a5] 
[ 86943.235] 10: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f1482528000+0xff713) [0x7f1482627713] 
[ 86943.235] 11: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f1482528000+0 
x528dd2) [0x7f1482a50dd2] 
[ 86943.235] 12: /usr/bin/X (0x400000+0xf9793) [0x4f9793] 
[ 86943.235] 13: /usr/bin/X (0x400000+0x31c09) [0x431c09] 
[ 86943.235] 14: /usr/bin/X (0x400000+0x35cd9) [0x435cd9] 
[ 86943.235] 15: /usr/bin/X (0x400000+0x24f0a) [0x424f0a] 
[ 86943.235] 16: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f14873e54bd] 
[ 86943.235] 17: /usr/bin/X (0x400000+0x24aa9) [0x424aa9] 
[ 86943.235] 
[ 86943.235] [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack. 
[ 86943.235] [mi] mieq is *NOT* the cause.  It is a victim. 
[ 86943.443] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00004908, 0x000050ac) 
[ 86950.443] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00004908, 0x000050ac) 
[ 86950.443] [mi] Increasing EQ size to 512 to prevent dropped events. 
[ 86950.443] [mi] EQ processing has resumed after 55 dropped events. 
[ 86950.443] [mi] This may be caused my a misbehaving driver monopolizing the server's resources. 
[ 86953.448] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00004908, 0x00002fac) 
[ 86960.448] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00004908, 0x00002fac) 
[ 87021.157] (EE) NVIDIA(0): Failed to allocate 2D engine 
[ 87021.157] (EE) NVIDIA(0):  *** Aborting *** 
[ 87021.157] (EE) NVIDIA(0): Failed to allocate 2D objects 
[ 87021.157] (EE) NVIDIA(0):  *** Aborting *** 
[ 87021.157] (EE) NVIDIA(0): Error recovery failed. 
[ 87021.157] (EE) NVIDIA(0):  *** Aborting *** 
[ 87024.158] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00000000, 0x0000013c) 
[ 87028.151] (WW) NVIDIA(0): WAIT (0, 6, 0x8000, 0x0000013c, 0x0000013c) 
[ 87032.173] (EE) NVIDIA(0): Failed to allocate 2D engine 
[ 87032.173] (EE) NVIDIA(0):  *** Aborting *** 
[ 87032.173] (EE) NVIDIA(0): Failed to allocate 2D objects 
[ 87032.173] (EE) NVIDIA(0):  *** Aborting ***
The screen would start flickering, and eventually freeze. The only way to recover would be to kill the X server.

Downgrading back to the 295 driver appears to have solved the problem. Any ideas what's going on with the driver?

Cheers,

EE
ExecutorElassus is offline   Reply With Quote