View Single Post
Old 06-26-12, 02:56 PM   #7
Artefact2
Registered User
 
Join Date: Jun 2012
Posts: 6
Default Re: Multiseat X with two cards: used to work, now segfaulting

Quote:
Originally Posted by AaronP View Post
That shouldn't have worked with a multiseat configuration either.

If you want to combine the physical X screens into one logical X screen, you can use Xinerama or the BaseMosaic option.
Actually, since I used to use twinview for the first Xorg server, I was able to swap windows between the middle and the right monitors.

Also, as I said in my main post, Xinerama works but has completely horrible 3D performance (I assume that's because all the screen merging is done in software).

BaseMosaic I have never even heard about before (and I did a lot of searching, hehe), but it seems promising. I'll give it a try, thanks!

Edit: I tried BaseMosaic option, and it seems to be SLI-only… Maybe I am doing it wrong?
Code:
[ 42299.984] (**) NVIDIA(0): Option "BaseMosaic" "True"
[ 42299.984] (**) NVIDIA(0): Option "MetaModes" "GPU-0.DFP-0: nvidia-auto-select +1920+0, GPU-0.DFP-2: nvidia-auto-select +3840+0, GPU-1.DFP-0: nvidia-auto-select +0+0"
[ 42299.984] (**) NVIDIA(0): Enabling 2D acceleration
[ 42300.979] (EE) NVIDIA(0): Failed to find a valid Base Mosaic configuration.
[ 42300.979] (EE) NVIDIA(0): Invalid Base Mosaic configuration 1 of 1:
[ 42300.979] (EE) NVIDIA(0): GPUs:
[ 42300.979] (EE) NVIDIA(0):     1) NVIDIA GPU at PCI:1:0:0
[ 42300.979] (EE) NVIDIA(0):     2) NVIDIA GPU at PCI:2:0:0
[ 42300.979] (EE) NVIDIA(0): Errors:
[ 42300.979] (EE) NVIDIA(0):     - The video link was not detected
[ 42300.979] (EE) NVIDIA(0):     - Chipset not approved for SLI
Which is confusing because the README says "This is like SLI Mosaic mode except that it does not require a video bridge connected to the graphics cards."
Artefact2 is offline   Reply With Quote