Thread: Acceleration
View Single Post
Old 01-09-04, 10:36 AM   #3
Spooky
Registered User
 
Join Date: Jan 2004
Posts: 7
Default

Not exactly.
I used nvidia-installer and it did the job. For the XFree86-Mesa-GL prob, I was already aware of it so I erased that packages files without removing the package to avoid dependencies problems with apt/yum.

Anyway, the glxinfo seems to show that the GL libraries used are real nvidia's.
glxinfo | grep -i nvidia =>

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
OpenGL version string: 1.4.1 NVIDIA 53.28

what's more, glxgears seems to be linked with the correct files :
ldd /usr/X11R6/bin/glxgears =>
libGL.so.1 => /usr/lib/tls/libGL.so.1 (0x0073c000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00c50000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00b70000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00c96000)
libm.so.6 => /lib/tls/libm.so.6 (0x00b47000)
libc.so.6 => /lib/tls/libc.so.6 (0x00a0c000)
libGLcore.so.1 => /usr/lib/tls/libGLcore.so.1 (0x0664d000)
libdl.so.2 => /lib/libdl.so.2 (0x00b6b000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x009f4000)

ls -l /usr/lib/tls/libGL.* =>
-rw-r--r-- 1 root root 636 Jan 8 18:55 /usr/lib/tls/libGL.la
lrwxrwxrwx 1 root root 10 Jan 8 18:55 /usr/lib/tls/libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root 17 Jan 8 18:55 /usr/lib/tls/libGL.so.1 -> libGL.so.1.0.5328
-rwxr-xr-x 1 root root 393468 Jan 8 18:55 /usr/lib/tls/libGL.so.1.0.5328

Any idea ?
Spooky is offline   Reply With Quote