View Single Post
Old 08-13-12, 09:31 PM   #4
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Nvidia 304.32 new xorg.conf update breaks panning

Quote:
Originally Posted by NHOjar View Post
Dear Leigh,

I have reviewed the documents and I do not see anything that will not support the panning that was working up to 2 days ago. I have not changed the Kernel or graphics driver for a while, at least 1 month I would say. The kmod-nvidia for the kernel was downloaded even when I had already build it using akmods.

The panning has been working for at least 1 year. I have used the nvidia-settings utility without ever seeing an error message, not even with the "autofix"

The panning area is available, but Docky appears at the bottom of the 1920x1080 and not at the bottom of 1920x1400 level.

a. I have re-copied over the nvidia-xorg.conf and over-written the xorg.conf
b. I ran up the nvidia-settings utility, as root, and after I defined panning, while saving I got a warning that the configuration had an error, one line was too long. I chose to fix the line myself per the nvidia guide on how to setup panning.
c. The old line was too long, defining multiple un-nececessary values with "Auto". I have reduced the value to the minimum, logged out and then back in with no difference with the panning space being blank.

current stanza:-
# Removed Option "metamodes" "DFP-0: 1920x1080 +0+0, CRT: 1680x1050 +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: 1680x1050 +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

========

Previous section from earlier file:-

# Removed Option "metamodes" "DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: 1680x1050 @1680x1400 +1920+0; CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_75 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1600x1000 +0+0; CRT: 1600x1000_60 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_72 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; DFP-0: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_75 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1600x1000 +0+0; CRT: 1600x1000_60 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_72 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: 1680x1050 @1680x1400 +1920+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select +1920+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select @1680x945 +1920+0"
SubSection "Display"
Depth 24
EndSubSection

================================================== =
# uname -a ; rpm -qa | grep nvidia ; cat /etc/X11/xorg.conf
Linux naipaulpc 3.4.7-1.fc16.x86_64 #1 SMP Mon Jul 30 16:37:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
kmod-nvidia-3.4.7-1.fc16.x86_64-304.32-2.fc16.x86_64
akmod-nvidia-304.32-2.fc16.x86_64
kmod-nvidia-3.4.4-4.fc16.x86_64-304.32-2.fc16.x86_64
xorg-x11-drv-nvidia-libs-304.32-1.fc16.x86_64
kmod-nvidia-3.4.6-1.fc16.x86_64-295.59-1.fc16.5.x86_64
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-drv-nvidia-304.32-1.fc16.x86_64
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.49 (mockbuild@builder1.ovh.rpmfusion.lan) Thu May 3 20:10:18 CEST 2012

# RPM Fusion - nvidia-xorg.conf
#

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Lenovo Group Limited"
HorizSync 56.5 - 67.8
VertRefresh 50.0 - 60.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro 2000M"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Monitor "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: 1920x1080 +0+0, CRT: 1680x1050 +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: 1680x1050 +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
I built the nvidia driver package your running less than ten days ago!
Code:
akmod-nvidia-304.32-2.fc16.x86_64

http://download1.rpmfusion.org/nonfr...od-nvidia.html
__________________
leigh123linux
leigh123linux is offline   Reply With Quote