View Single Post
Old 11-01-12, 02:50 AM   #1
blujay
Registered User
 
Join Date: Oct 2005
Posts: 14
Default JPEG causes X and NVIDIA driver to freeze

Visiting this web page in either Firefox or a different, WebKit-based browser causes X to freeze at 100% CPU:

http://www.fountainpennetwork.com/fo...erlord-orange/

The first time I went to the page, the second sample image in the first post was a weird jumble of areas of the screen that were or had recently been visible. When I opened the image in a tab, X froze. The cursor was sometimes still movable.

I rebooted and went to the page in Firefox again, and it froze X without opening the image separately.

I rebooted and opened the page in the WebKit browser, and X froze again.

I think the image in question is this one, the second:

http://i1248.photobucket.com/albums/...servations.jpg

But I'm not completely sure if it's that one or the third one. It's hard for me to test since it causes the crash.

I visited the page in Firefox on another computer with an AMD chipset using the open-source drivers, and there was no crash.

The Xorg.log file showed this after X froze:

Code:
[   428.025] (EE) NVIDIA(0): Failed to allocate 2D engine
[   428.025] (EE) NVIDIA(0):  *** Aborting ***
[   428.025] (EE) NVIDIA(0): Failed to allocate 2D objects
[   428.025] (EE) NVIDIA(0):  *** Aborting ***
[   428.025] (EE) NVIDIA(0): Error recovery failed.
[   428.025] (EE) NVIDIA(0):  *** Aborting ***
[   436.027] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00000000, 0x0000002c)
[   443.027] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00000000, 0x0000002c)
[   451.086] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00000000, 0x00001c88)
[   458.086] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00000000, 0x00001c88)
[   461.088] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00000000, 0x00002560)
[   468.088] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00000000, 0x00002560)
I'm using a Dell XPS M1330 laptop with NVIDIA 8400M chipset, running on Ubuntu 12.04 Precise. I realize I'm using an older driver, but the up-to-date driver causes crashes and freezes when playing video. This is the most recent one that doesn't cause that problem. (Of course, using Oneiric and any other release of Ubuntu going back to 8.04, neither problem ever occurred. Something went haywire in the NVIDIA driver after 280.13, and I appear to be stuck with this version until who-knows-when.)
Attached Files
File Type: gz nvidia-bug-report.log.gz (62.7 KB, 60 views)
blujay is offline   Reply With Quote