View Single Post
Old 11-07-12, 01:49 PM   #1
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Unable to disable vsync for XGL

I have been running pretty old 270.x drivers because the newer ones changed the behavior where vsync is enabled by default now (NOOOO).

I have a triple monitor setup at work and it syncs to my lowest refresh rate monitor which is only 48Hz which is horrible for the other two (67Hz and 60 Hz).

I have tried adding:

nvidia-settings --load-config-only

to my xinitrc and also in kdm's kdmrc file I tried adding:

# Additional environment variables KDM should pass on to all programs it runs.
# LD_LIBRARY_PATH and XCURSOR_THEME are good candidates;
# otherwise, it should not be necessary very often.
# Default is ""
ExportList=__GL_SYNC_TO_VBLANK=0

I wonder if its not taking effect as maybe these things environment variables dont work until after X is loaded? That is a problem as XGL is openGL based and what everything runs under and is pretty much the main process which is running =(

Nothing seems to work. beryl bench is still showing 48 FPS which is driving me nuts. With steam for linux coming out I really want to use newer drivers now. Anyone have any ideas on getting around this? An option in /etc/X11/xorg.conf would have been nice for over-riding this default =(
Xevious is offline   Reply With Quote