View Single Post
Old 11-07-12, 05:30 PM   #2
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Unable to disable vsync for XGL

I have even verified the environment variables are being set but vsync is still being enabled. Using the old driver I get 200-300 FPS after the first boot and with the newer ones I am stuck at 48 FPS:

Code:
root@sigoto: 03:27 PM :~# ps aux | grep X | grep -v grep | grep -v Box
root     17205 24.1  5.0 1385100 1257364 ?     R    15:22   1:12 /usr/bin/Xgl.actual -accel xv:fbo -accel glx:pbuffer -nolisten tcp -fullscreen -br +xinerama -nolisten tcp -dpi 75 :0 vt7 -auth /var/run/xauth/A:0-dH33XM
root     17218  0.9  0.1 111704 45912 tty7     Ss+  15:23   0:02 /usr/bin/Xorg -br vt7 -auth /tmp/.Xgl-auth-68Xx9z -nolisten tcp :93 -terminate
root@sigoto: 03:27 PM :~# cat /proc/17205/environ  | awk -F'_GL' '{print "__GL"$2}' | cut -c 1-21
__GL_SYNC_TO_VBLANK=0
root@sigoto: 03:28 PM :~# cat /proc/17218/environ  | awk -F'_GL' '{print "__GL"$2}' | cut -c 1-21
__GL_SYNC_TO_VBLANK=0
Any other way to disable vertical sync other than environment variables? They don't appear to always work with everything.
Xevious is offline   Reply With Quote