View Single Post
Old 01-13-04, 04:36 PM   #2
zerohour
Registered User
 
Join Date: Jan 2004
Posts: 2
Default

Hey there,

You're suffering from clock drift... Try recompiling your kernel with the
options 'CONFIG_X86_TSC_DISABLE' flag switched on. (Flip the
'Unsynced TSC support' in the cpu section of the configuration options).

Quoting the kernel documention:
" This option is used for getting Linux to run on a NUMA multi-node
boxes, laptops and other systems suffering from unsynced TSCs or
TSC drift, which can cause gettimeofday to return non-monotonic values.
Choosing this option will disable the CONFIG_X86_TSC optimization,
and allows you to then specify "notsc" as a boot option regardless of
which processor you have compiled for."

Try and see if it helps,

zerohour
zerohour is offline   Reply With Quote