View Single Post
Old 01-17-04, 05:10 PM   #1
Ardeaem
Registered User
 
Join Date: Sep 2003
Posts: 5
Default GeForce 2 GTS, RH9, X, TV-out

I had an ATI Radeon 7000 working on this machine with X, but, as many of you probably know, they don't have ANY linux drivers, so I couldn't do anything accellerated in linux. So, I decided to use my GeForce 2 GTS-class card in the system (It is running RH9).

I'm using a TV-out via the S-Video. It starts up fine. I installed the NVidia 5328 drivers. Everything installed fine. When I try to start X, though, I get a lot of colored garbage and flickering for about 3 seconds, then it settles down to a black screen. It looks like it also has grey borders.

X is running, I think, but not displaying properly. When I Ctrl-Alt-F1 to the console I see that the last thing that is printed is generally "Initializing GLX" or something like that. Also, when I Ctrl-C to break out of X at the console, I sometimes get messages from applications saying that they can't reach the X server. So it seems to be working, just not displaying correctly.

Anyway, I'd love to finally get this working. I have attached my XF86Config and my XFree86.0.log, which I did in verbose mode. Thanks.

RedHat 9
Athlon 500 MHz
Geforce 2 GTS (I believe is is some kind of special edition with 64 Meg RAM)

Richard

BEGIN XF86Config:
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "TV"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 30-50
VertRefresh 60
EndSection

Section "Device"
Identifier "Gforce"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 GTS (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Gforce
Monitor "TV"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "SVIDEO"
EndSubSection
EndSection
Attached Files
File Type: log xfree86.0.log (26.2 KB, 165 views)
Ardeaem is offline   Reply With Quote