View Single Post
Old 01-22-04, 02:06 AM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default You must use 'nv' rather than 'vesa'

The generic FX card setup in Redhat 9 will use the 'vesa' X driver, one that is not well supported for the FX chipset. The necessary fix is to switch the used driver to the 'nv' driver instead. You have several options for doing this, but the two simplest are:

Reinstall Redhat, but choose 'Geforce 2 generic" instead of FX generic. This should use the 'nv' driver instead of the 'vesa' driver. Do this if you have difficulty trying the better option below.

You need to first boot the machine into single user mode or use the redhat cd to enter rescue mode. Use 'linux rescue' at the first prompt on the cd, or to boot to single user mode, you need to add an option to the kernel line of the lilo config, I don't use lilo so I'm not much help with this. The option you would need to add is: init 1

Once you have a terminal prompt, either by rescue mode or single user mode, you need to edit a config file, you can do this with one of several terminal text editors (joe, pico, vi, emacs). If you need to, search google for a short tutorial on one of them.

Edit the file: /etc/X11/XF86Config
Find the line that reads: Driver "vesa"
Change it to read: Driver "nv"
Save the file.

You can now reboot and use X.

Fedora Core 1 should handle the video card correctly from the beginning. I suggest you consider using Fedora, since Redhat 9 is a discontinued product of Redhat, which will not have continued security patch releases.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote