View Single Post
Old 01-25-04, 09:25 PM   #1
OU812
Registered User
 
Join Date: Jan 2004
Location: Atlanta, GA
Posts: 3
Exclamation FreeBSD 4365 driver will not initialize

I have a personal panic going on here with a machine that I need to get into service and it will not start x.

The HW is a P4 3.0Gz/800FSB/HT in an Abit Ic7 mobo with 1G of memory.

It is a fresh install of FreeBSD RELEASE on the 4 branch (4.9 is the new one) and I configured the kernel per the directions in the driver. It compiled and installed clean. I have tried the startx with and without the AGP option in the kernel and I have tried it with and without the vesa option since I read someplace that might make a difference. I do not know if I have tried every combination of both.

The driver version is NVIDIA-FreeBSD-x86-1.0-4365.tar.gz and it downloaded, compiled and installed clean.

dmesg reports linux.ko and nvidia.ko are preloaded elf modules.

The bottom line is that it seems to do everything right right up to the point where it loads the screen section and then I get:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!

It then aborts, unloads the modules (nvidia, vgahw and libvgahw.a) and then gives me:

(EE) Screen(s) found, but none have a usable configuration.

I have attached the XFree86.0.log (I ran it -verbose) and the XF86Config that I used is the sample one with modifications. I removed everything but the single AGP card configurations and modified the horiz and vert rates. I can post it if you want it.

If you have solved this problem or can help me do so... i'm beggin here.

Thanks all.
Attached Files
File Type: log xfree86.0.log (17.7 KB, 239 views)
__________________
People who never get carried away should be.
OU812 is offline   Reply With Quote