View Single Post
Old 01-31-04, 01:30 PM   #1
nashirak
Registered User
 
Join Date: Dec 2002
Posts: 14
Default Games Cant Find OpenGL

Hey I am using the 5328 drivers. I tried installing the 5336 drivers but I kept getting errors like:
ERROR: Unable to determine the NVIDIA kernel module filename.

And yes all the source packages were installed linked etc. It appears some other ppl are having trouble with it as well:

http://www.nvnews.net/vbulletin/show...threadid=24184
http://www.nvnews.net/vbulletin/show...threadid=24242
http://www.nvnews.net/vbulletin/show...threadid=24133

so its not just me:

http://www.nvnews.net/vbulletin/show...threadid=24225

A bug mabye?

Anyway I got the 5328 drivers to install without a hitch. I am having problems though running games (Armyops and UT and UT2003). They cant seem to load the OpenGL drivers. I have checked my /usr/lib/ to make sure the libGL files are there it returns:

libGL.la
libGL.so -> libGL.so.1
libGL.so.1 -> libGL.so.1.0.5328
libGL.so.1.0.5328
libGLU.a -> ../X11R6/lib/libGLU.a
libGLU.so -> libGLU.so.1.3
libGLU.so.1 -> libGLU.so.1.3
libGLU.so.1.3 -> ../X11R6/lib/libGLU.so.1.3
libGLcore.so.1 -> libGLcore.so.1.0.5328
libGLcore.so.1.0.5328

I can also run glxgears and get around 1800 fps.
glxinfo does return information as well. I used to be able to run these games before I updated my NVIDIA drivers. Any thoughts?

(XFree86 config is attached, system is a debian Geforce3 card 64mb)

Thx


# XFree86 4.0 configuration generated by Xconfigurator

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# By default, Red Hat Linux 6.0 and later use xfs

Section "Files"
FontPath "unix/:7100"
EndSection

# This loads all the modules...

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
# Load "pex5"
Load "record"
Load "xie"
Load "v4l"
Load "type1" #added to make abi work
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "ExplorerPS/2"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
Option "Resolution" "640"
EndSection

Section "Monitor"
Identifier "Princeton EO900"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30 - 95
VertRefresh 50 - 160
EndSection

Section "Device"
Identifier "nVidia Corporation|NV15 (Geforce2 GTS)"
# Driver "nv"
Driver "nvidia"
Option "NvAgp" "1"
VideoRam 65536
# BusID "PCI:1:0:0"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "nVidia Corporation|NV15 (Geforce2 GTS)"
Monitor "Princeton EO900"
DefaultDepth 24
Subsection "Display"
Depth 32
# Modes "1600x1200"
Modes "1280x1024"
Modes "800x600"
EndSubSection
Subsection "Display"
Depth 24
# Modes "1600x1200"
Modes "1280x1024"
Modes "800x600"
EndSubSection
Subsection "Display"
Depth 16
# Modes "1600x1200"
Modes "1280x1024"
Modes "800x600"
EndSubSection
EndSection

#Section "DRI"
#Mode 0666
#EndSection
nashirak is offline   Reply With Quote