View Single Post
Old 02-03-04, 08:57 PM   #19
slothman
Registered User
 
Join Date: Jan 2004
Posts: 10
Exclamation I think I know the problem

I also have Suse 9.0. Ok...You say that X server crashes and Sax2 hangs? I had this problem. My guess is, you installed installed Suse 9.0, then installed the Nvidia driver, THEN ran YOU update afterwards. YOU installed a newer version of your linux kernel (containing security fixes). The new kernel installation corrupted your Nvidia driver install.

Here is the solution that worked for me: Re-install Suse 9.0 from scratch and include the linux kernel source in your installation (not installed by default). Perform YOU update (YOU will update your kernel AND your kernel source). Now, install the Nvidia driver in Linux safemode. The Nvidia installer will tell you it has no interface that matches your current kernel. The Nvidia installer will opt to compile the Nvidia driver for your kernel version using your kernel source files. Next, run Sax2 -m 0=nvidia.

(note: in Sax2, 3D acceleration will appear disabled but as long as your monitor and graphics card are properly selected, you will have 3D acceleration. It should be apparent in your XFREE86Config file.)

Now, if you do an lsmod, you should see something like this:
Module Size Used by Tainted: P
snd-pcm-oss 50976 0 (autoclean)
snd-mixer-oss 16184 1 (autoclean) [snd-pcm-oss]
ide-cd 32512 0 (autoclean)
cdrom 29760 0 (autoclean) [ide-cd]
snd-seq 44208 1 (autoclean)
videodev 6432 0 (autoclean)
agpgart 46776 3 (autoclean)
nvidia 1965408 6 (autoclean)
....etc.

Hope this helps.
slothman is offline   Reply With Quote