View Single Post
Old 02-04-04, 10:08 PM   #25
lemptee
Registered User
 
Join Date: Feb 2004
Location: Rochester, NY
Posts: 1
Default

OK.. this is what I would do. I've been messing around with suse 9 and the nvidia installer alot lately and run accross a bunch of different problems. First off, get your suse cds out.

1) boot into single user mode. you don't want to have the xserver kick up until you're sure it works. You can do this by typing 'single' the options field on the grub boot menu.
2) log in using the root password and ype yast. Make sure you have the kernel sources installed because the nvidia installer will need this to compile the nvidia kernel modules.
3)in yast, go to the online update section and make sure you have all the latest updates.
4) find whatever nvidia installer you used and pass it an '-uninstall' arguement to remove the nvidia xserver and kernel modules.
5)type 'init 3' at the root prompt to go into multi user mode with network access.
6)type 'sax2 -r' which will have sax redetect all of your settings. Make sure everything is fine with the non nvidia xserver. configure it and get out.
7)At this point you guys may know something I don't but I only have luck installing the nvidia drivers version 4496. The newer ones don't seem to jive with sax2 and it also seems to be the most stable with me. It should fail to find a precompiled module on the ftp server and compile it's own modules and install them.
8) type 'sax2' and configure your graphical setting select 'Enable 3D' this time. Test and save. Hopefully it worked.
9) get the newest nvidia drivers and install them
10) the type 'init 5' and bring up the graphical interface.

I kinda flew through this so I know it's not the best instructions but I hope this gets you somewhere
lemptee is offline   Reply With Quote