View Single Post
Old 02-09-04, 02:54 PM   #1
TadeuszJL
Registered User
 
Join Date: Feb 2004
Location: Austin, TX
Posts: 6
Question TwinView problems ?

Hello,

I have MSI FX 5600 XT 128MB configured as TwinView, with two DELL P1110 monitors. Previously I had two GeForce (2/4) cards set in Xinerama and it worked fine, but with recent upgrade to kernel 2.4.20-28.7 it started crashing at the close of my typical application, so I bought better card (albeit the cheapest with dual outputs - VGA + DRI->VGA plug) and set it in TwinView. Setup was a snap, crashes are history, OpenGL is on both screens, but I have persistent "blinking" of the left screen (every few minutes, no regularity or obvious cause, just few frames scrambled). I tried replacing the card (similiar from different manufacturer - no change), I tried reducing top frequency, same.

Any suggestions ?????

Here is the setup:

Section "Screen"
Identifier "Screen"
Device "NVIDIA GeForce 2 MX (generic) (AGP)"
Monitor "Monitor0"
DefaultDepth 24

Subsection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "640x480"
EndSubsection

Option "TwinView"
Option "SecondMonitorHorizSync" "30.0-101.0"
Option "SecondMonitorVertRefresh" "48.0-160.0"
Option "MetaModes" "1600x1200,1600x1200; 1280x1024,1280x1024"

EndSection

True upper Horiz is 121, the screens are then at 105kHz/85Hz, after change it is 94/75. In both cases it is sin to waste good monitor on low freq, but I'm not ready to spend on $400 card (its company money ...)

RedHat 7.3, Athlon 2400, SiS mbrd (ECS K7S5A Pro)
NVIDIA-Linux-x86-1.0-5328-pkg1.run

BTW - I assumed that TwinView requires single video card and it will not work on my previous hardware. Is it true ? README is not explaining it clearly ....


thanks
__________________
Tadeusz
TadeuszJL is offline   Reply With Quote