View Single Post
Old 02-12-04, 03:50 PM   #1
Richard Pan
Registered User
 
Join Date: Feb 2004
Location: Washington, DC
Posts: 1
Default HELP! Red Hat Professional Workstation installation problem!!

dear Andy and others, hi, i tried to install Red Hat Professional Workstation, out of a store-bought red box product, for the first time and am having serious difficulties. i need to install NVIDIA drivers for this version of Red Hat Enterprise Linux, which has kernel 2.4.21-4.EL and
should be Enterprise Linux 3.0.

i should state i did an installation of NVIDIA drivers earlier for Red Hat
Linux 8.0 (the NVchooser.sh & driver 1.0-4191 version worked flawlessly the first time) on this same machine. the display adaptor for my pc is a
NVIDIA GeForce4 MX Integrated GPU with NVIDIA NForce MCP2 IDE
Controller.

however, for this Red Hat Professional Workstation version of Enterprise
Linux, nothing seems to work! as before, i chose not to select the X Windows configuration during installation of Professional Workstation b/c
there wasn't an exactly correct choice (GeForce4 MX Integrated GPU) available on the list shown. following instructions

root / > sh NVIDIA-Linux-x86-1.0-5336-pk1.run
seemed to install the NIVIDIA driver, but there is no XFree86Config file to
update! this is what i got in the /etc/X11/ directory,

++++++++++++++++++++++++++++++++++++++++++++++++++ +
total 84
drwxr-xr-x 16 root root 4096 Feb 8 20:53 .
drwxr-xr-x 69 root root 8192 Feb 12 15:11 ..
drwxr-xr-x 3 root root 4096 Feb 8 20:56 applnk
drwxr-xr-x 2 root root 4096 Feb 8 20:49 desktop-menus
drwxr-xr-x 2 root root 4096 Feb 8 21:14 fs
drwxr-xr-x 6 root root 4096 Jul 23 2003 gdm
drwxr-xr-x 2 root root 4096 Feb 8 20:53 lbxproxy
-rwxr-xr-x 1 root root 1419 Sep 26 00:39 prefdm
drwxr-xr-x 2 root root 4096 Feb 8 20:53 proxymngr
drwxr-xr-x 2 root root 4096 Jan 24 2003 serverconfig
drwxr-xr-x 2 root root 4096 Feb 8 20:49 starthere
drwxr-xr-x 2 root root 4096 Jan 24 2003 sysconfig
drwxr-xr-x 2 root root 4096 Feb 8 20:53 twm
drwxr-xr-x 3 root root 4096 Feb 8 20:55 xdm
-rw-r--r-- 1 root root 372 Oct 3 06:17 XftConfig.README-OBSOLETE
drwxr-xr-x 3 root root 4096 Oct 3 06:17 xinit
lrwxr-xr-x 1 root root 27 Feb 8 20:53 xkb -> ../../usr/X11R6/lib/X11/xkb
-rw-r--r-- 1 root root 613 Feb 5 2003 Xmodmap
-rw-r--r-- 1 root root 492 Feb 5 2003 Xresources
drwxr-xr-x 2 root root 4096 Feb 8 20:53 xserver
drwxr-xr-x 2 root root 4096 Feb 8 20:53 xsm
++++++++++++++++++++++++++++++++++++++++++++++++++ ++


You requested the /var/log/XFree86.0.log, which is shown here,
++++++++++++++++++++++++++++++++++++++++++++++++++ ++
XFree86 Version 4.3.0 (Red Hat Enterprise Linux release: 4.3.0-35.EL)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.21-2.ELsmp i686 [ELF]
Build Date: 03 October 2003
Build Host: daffy.perf.redhat.com

Before reporting any problems, please make sure you are using the most
recent XFree86 packages available from Red Hat by checking for updates
at http://rhn.redhat.com/errata or by using the Red Hat Network up2date
tool. If you still encounter problems, please file bug reports in the
XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
bugzilla at http://bugzilla.redhat.com

Module Loader present
OS Kernel: Linux version 2.4.21-4.EL (bhcompile@daffy.perf.redhat.com) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-20)) #1 Fri Oct 3 17:52:56 EDT 2003 P
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Feb 12 13:01:20 2004
(EE) Unable to locate/open config file
(EE) Error from xf86HandleConfigFile()

Fatal server error:
no screens found

If you encounter a server crash, please report the problem by filing a bug
report in the XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
bugzilla at http://bugzilla.redhat.com/bugzilla. When filing your report, it
is very important that you explain your problem in as much detail as possible,
and include a complete description on how to reproduce the problem. After
submitting the bug report, attach the following files as uncompressed
individual file attachments using the bugzilla file attachment feature:
- X server log file: /var/log/XFree86.0.log
- Kernel log file: /var/log/messages
++++++++++++++++++++++++++++++++++++++++++++++++++ ++


what am i doing wrong? have i got the wrong Linux driver? i chose this one, 5328, because the website, http://www.nvidia.com/object/linux_d..._1.0-5328.html ,
says "Added support for Red Hat Enterprise Linux 3.0" . No other driver
webpage says that.

Or, do i need to find a xfconfig86 program on the web and run it on my
machine to generate a correct XFree96Config file?

Andy, thank you so much in advance for help!!!!

Richard Pan, Washington, DC 202 829-9732
Richard Pan is offline   Reply With Quote