View Single Post
Old 02-15-04, 05:14 PM   #1
Nico09
Registered User
 
Join Date: Feb 2004
Location: South of France
Posts: 3
Default twinview "clone" + tvout = screen too wide !

Hi !

First my config :

Vidéo card : Leadtek A250LE MyVIVO GeForce 4 Ti 4200.
Driver version : NVIDIA-Linux-x86-1.0-5336-pkg1
Distribution : Debian unstable.
Xfree version : 4.3.0
Video bios revision : 04.25.00.30.00
Processor : P 4 2.0 Ghz
Motherboard : ASUS P4G8X.
TV : Sony 19/9 100Hz

I just want running twinview in clone mode with a CRT Monitor and a tv (for watching dvd ...)
In my XF86Config-4 file (attached) there is 2 mode 1024x768 and 800x600.
When I start everything it's ok, monitor's screen is in good résolution and tv's screen is black.
But when I switch in 800x600 mode monitor's screen becomes too wide (I can move it with my mouse) and same on tv's screen. It impossible watching movies because only part of picture is display.
I tried other mode like 640x480 and less but it's worse.

I don't know if it's important but when I boot with tv connected half of my monitor's screen is black under non-X mode (console).

I search alone since a couple of days (even on this forum) but I don't find solution so please help me.

I'm realy sorry for my english.

My XF86Config-4 file

Quote:
Section "Files"
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
# Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "MouseManPlusPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "nvidia"
VendorName "NVidia"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
Driver "nvidia"
Option "UseEdidFreqs" "0"
Option "NvAGP" "2"
Option "NoLogo"
Option "TwinView" "True"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "TwinViewOrientation" "Clone"
Option "MetaModes" "1024x768;800x600,800x600;"
Option "ConnectedMonitor" "CRT-0, TV-0"
Option "TVOutFormat" "SVIDEO"
EndSection

Section "Monitor"
Identifier "iiyama"
VendorName "Iiyama"
ModelName "MT-901E, VisionMasterPro"
HorizSync 27-92
VertRefresh 50-160
Modeline "1152x864" 121.50 1152 1216 1344 1568 864 865 868 911 +hsync -vsync
Option "dpms"
EndSection

Section "Screen"
Identifier "screen"
Device "nvidia"
Monitor "iiyama"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
Option "TVStandard" "PAL-N"
EndSection

Section "ServerLayout"
Identifier "Layout"
Screen "screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Attached Files
File Type: log xfree86.0.log (41.2 KB, 103 views)
Nico09 is offline   Reply With Quote