Thread: Fedora & Tnt2
View Single Post
Old 02-18-04, 05:26 PM   #10
macemoneta
Registered User
 
macemoneta's Avatar
 
Join Date: Oct 2002
Location: NJ
Posts: 159
Default __GL_SYNC_TO_VBLANK=0

Thanks CrLf, that did the trick. I did read ALL the related forum posts first. The only mention of this setting in the forums, is in these threads:

1.0-5328 released:
http://www.nvnews.net/vbulletin/show...NCTOVBLANK%3D0

How to disable vsync (problems with the 5200 card, not TNT2):
http://www.nvnews.net/vbulletin/show...NCTOVBLANK%3D0

Turning OFF vsync (Quake 3 problem resolution):
http://www.nvnews.net/vbulletin/show...NCTOVBLANK%3D0

It's unlikely that anyone searching for problems with the TNT2 and 5336 release will be able to find this solution, except in this thread. It would have been nice if NVIDIA had included mention of the change in the release notes. Instead, the release notes specifically indicate that the setting DOESN"T APPLY to the TNT2:

"Setting the environment variable __GL_SYNC_TO_VBLANK to a non-zero value
will force glXSwapBuffers to sync to your monitor's vertical refresh rate
(perform a swap only during the vertical blanking period) on GeForce or
newer hardware (ie: everything but TNT/TNT2 products)."

The release notes need a BOLD statement AT THE TOP, whenever a change like this is made, so that people at least have a chance to find it.
macemoneta is offline   Reply With Quote