View Single Post
Old 10-12-02, 05:53 PM   #1
ltgnome
Registered User
 
Join Date: Oct 2002
Location: germany
Posts: 4
Question Frozen screen with GeForce2 GTS and SuSE 7.3, 8.0, 8.1

Help!!!
I need some antifreeze for my PC-screen – and haven't found it yet!

Ok. – here is my problem:
I use a nVIDIA GeForce2-GTS. No problems with windows, but a lot with Linux and the nVIDIA drivers: after some minutes the screen „freezes“, the mouse-cursor is still moving but clicking has no effect (and no changes in the cursors shape), the keyboard is „dead“, no key incl. Num-Lock, Caps-Lock gives any response. The system is running, you can see some activity of the harddisk, when connecting an USB-device (e.g. mouse), the system obviously reacts – but I still have no device to do anything with that system: keyboard and mouse have no function at all. I tried to wait some time, hoping the „frozen-running“ system would change the status in any way, but after two hours nothing had happened. The only possibility, to continue work is to use the reset-button!

I found a lot of hints in this forum, but nothing worked. Here are the details:

The problem occured with SuSE 7.3, SuSE 8.0 and SuSE 8.1 (all with reiser-fs). The problems occured with all (at least those I got in the past 18 months) versions of NVIDIA_GLX- and NVIDIA_kernel-packages. The problem occured with Gnome1.4 with sawfish, with Gnome2 and metacity, with KDE3.

In my case it's obviously not a problem of the kernel-version, the driver-version and it's not a problem of Gnome or Gnome2!

In all cases the installation was no problem (good README from NVIDIA!), no errors in XFree86.0.log after starting the X-System. The correct drivers were used, everything looked fine, testing shows that the drivers were doing there (good) work.

And after some minutes – frozen screen, dead keyboard. After the reset there are no errors in any message- or log-file – at least I found nothing at all.

I tried to use the source-rpms – no problems, everything worked as described. Startx – ok. XFree86.0.log – ok. And some minutes later – after freezing - the only difference: the mouse-cursor was „dead“, too.

I tried the <Option „NoRenderAccel“ „true“>. Good idea – I could work about ten minutes longer before the screen frozes...

I'm really a little bit „unhappy“! And I have no idea, what the cause for these problems should be! Perhaps someone knows an excellent antifreeze for me! Thank you!

Last edited by ltgnome; 10-18-02 at 06:35 PM.
ltgnome is offline   Reply With Quote