View Single Post
Old 02-20-04, 12:27 AM   #4
Lyndon
Registered User
 
Join Date: Feb 2004
Location: Discovery Bay, Hong Kong
Posts: 28
Default Problems

I have spotted some of the obvious problems:

[lyndon@tuxbox]$ cat /proc/driver/nvidia/cards/0
Model: GeForce FX 5600
IRQ: 16
Video BIOS: ??.??.??.??.??
Card Type: AGP
[lyndon@tuxbox]$



[lyndon@tuxbox]$ cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host Bridge
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0x1f000a1b:0x00000000
[lyndon@tuxbox]$

I have the KT600 Chipset not the KT400 as shown above.



[root@tuxbox]# cat /var/log/XFree86.0.log | grep '(EE)'
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
[root@tuxbox]#

Because GLX doesn't initialize the following is not a surprise:

[lyndon@tuxbox]$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
[lyndon@tuxbox]$



I have also noticed that there may be some weird permissions. Several files have been installed as executable. I don't think they need to be and pose a security risk, but I could be wrong on this one. Here is one example:

[lyndon@tuxbox]$ ll /usr/X11R6/lib/modules/extensions
total 3592
-r--r--r-- 1 root root 16852 Feb 12 11:49 libdbe.a
-r--r--r-- 1 root root 31828 Feb 12 11:49 libdri.a
-r--r--r-- 1 root root 169570 Feb 12 11:49 libextmod.a
-r--r--r-- 1 root root 2264136 Feb 12 11:49 libGLcore.a
-r--r--r-- 1 root root 454642 Feb 12 11:49 libglx.a
lrwxrwxrwx 1 root root 18 Feb 8 21:41 libglx.so -> libglx.so.1.0.5336*
-rwxr-xr-x 1 root root 646808 Feb 8 21:41 libglx.so.1.0.5336*
-r--r--r-- 1 root root 26260 Feb 12 11:49 librecord.a
-r--r--r-- 1 root root 40046 Feb 12 11:49 libxtrap.a
[lyndon@tuxbox]$


I will try to supply some more information, but I may wait until I hear from Andy Mecham. I don't want to spend too much time on incorrect troubleshooting. I will continue to read through the FAQ and search this forum.

Thanks in advance for any help.

Lyndon
Lyndon is offline   Reply With Quote