View Single Post
Old 10-12-02, 08:47 PM   #1
Posts: n/a
Default How do I enable TV Out?


Installation: Redhat 8 on P3 w/MSI GeForce4 MX460 VTP

I clean installed Redhat 8 with a CRT. Everything worked fine.

I upgraded to Nvidia Linux Drivers Version: 1.0-3123 and everything works fine.

I attempt to use TVOUT and I get garbled crap on the TV.

Here is my XF86Config file:

# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

FontPath "unix/:7100"


Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
# Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

# Option "AutoRepeat" "500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
# HorizSync 30.0-96.0
HorizSync 30-50
# VertRefresh 50.0-160.0
VertRefresh 60
Option "dpms"


Section "Device"
# no known options
Identifier "NVIDIA GeForce 4 (generic)"
# Driver "vesa"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
Option "ConnectedMonitor" "TV"


Section "Screen"
# Option "TwinView" "on"
# Option "SecondMonitorHorizSync" "range(s)"
# Option "SecondMonitorVertRefresh" "60"
# Option "MetaModes" "1024x768, NULL; NULL,1024x768; 1024x768,1024x768; 800x600,800x600; 800x600, NULL; NULL,800x600"
# Option "ConnectedMonitor" "CRT,TV"
# Option "TVStandard" "NTSC-M"
# Option "TVOutFormat" "SVIDEO"
# Option "TVOutFormat" "COMPOSITE"
# Option "ConnectedMonitor" "TV"

Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16
Option "TVStandard" "NTSC-M"

Subsection "Display"
Depth 16
# Modes "1024x768" "800x600" "640x480"
Modes "800x600" "640x480"
# Modes "640x480"


Section "DRI"
Mode 0666
  Reply With Quote