View Single Post
Old 02-21-04, 02:57 PM   #1
ducky
Registered User
 
Join Date: Feb 2004
Posts: 2
Unhappy Stuck at 1024 x 768

I have a GeForce 4 with 64 MB of ram and I've installed the latest drivers (version 1.0-5336) and for some reason X windows won't load at 1280 x 1024 and just loads at 1024 x 768. I searched the net and my monitor is capable of running at 1280 x 1024. Plus I've got it to run at 1280 x 1024 if I change the driver to "nv" instead of "nvidia". I'm using Red Hat 7.3 at the moment (long story) but I had the same problem on Redhat 9.

Also, for some strange reason the wallpaper is messed up underneath the icons on the desktop.

################### My XF86Config file ########################
# XFree86 4.2.0 configuration generated by Xconfigurator 4.10.7

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# Red Hat Linux 6.0 and later use the xfs font server for improved
# interactive performance

Section "Files"
FontPath "unix/:7100"
EndSection

# Module loading section

Section "Module"
Load "dbe" # Double-buffering
Load "GLcore" # OpenGL support
Load "dri" # Direct rendering infrastructure
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions
Load "v4l" # Video4Linux
# Load "record" # X event recorder
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1" # Adobe Type 1 font handler
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "on"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Acer 58c"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30 - 70
VertRefresh 50 - 120
Option "dpms"
EndSection

Section "Device"
Identifier "nVidia Corporation|NV17 [GeForce4 MX420]"
Driver "nvidia"
BoardName "Unknown"
EndSection

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "nVidia Corporation|NV17 [GeForce4 MX420]"
Monitor "Acer 58c"
DefaultDepth 16
Subsection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
Subsection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
Subsection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
ducky is offline   Reply With Quote