View Single Post
Old 10-14-02, 06:53 AM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: Confirmation on memory problem with Nvidia on Suse 8.0 and Red Hat 8.0

Quote:
Originally posted by wastrel
...the memory consumed slowly increases over time.
Up to what? Does the amount of memory used stay below the amount of physical memory you have?

Linux does not handle memory the same way as Windows does -- it will allocate free physical memory to things like caching filesystem data (to make FS searches faster the second time around), up to the point where only a small amount of physical memory is free. Then when a program needs some allocated, the kernel moves it from the FS cache to that program. Instead of maximizing the total amount of free memory, you should be trying to figure out if you're ever hitting your swap partition. If so, then you might have a problem (or just not enough memory).

You can run ps aux to get a one-shot listing of all the processes that are running. One of the columns is labeled %MEM; this is the column keeping track of the percentage of (virtual) memory that that specific process is taking up. Also, VSZ is the virtual-memory footprint of the program. Look for the largest %MEM and VSZ programs, and consider killing them off.

KDE is one usual culprit of memory hogging. X itself is another (but if X has a large VSZ, that's OK, because the stuff that's swapped out generally never swaps back in). I believe Gnome is fairly huge as well.

Since you have a non-XP/MP processor, have you tried passing mem=nopentium to your kernel at boot time? Upgrading to 2.4.19 doesn't fix the problem with plain Athlons, I believe. You could also try disabling AGP altogether (Option "NvAgp" "0"), as that would be another way to fix that problem. If you still get lockups, then the Athlon vs. AGP bug isn't what's causing them.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote