View Single Post
Old 02-28-04, 06:50 PM   #49
braindancer
Registered User
 
Join Date: Feb 2004
Posts: 1
Default modprobe nvnet fails

hi. i want to make my box a masq/nat box, thus i need my second nic (the nforce one)

my setup:
asus a7n8x deluxe
amd 2400+ 2ghz
256 mb 2700 corsair
old elsa gladiac that uses nvidia-linux-x86 drivers

so i compiled it by hand:
# make
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.23/build/include -DMODVERSIONS -include /lib/modules/2.4.23/build/include/linux/modversions.h nvnet.c
ld -r -o temp.o nvnet.o nvnetlib.o
objcopy --strip-symbol="gcc2_compiled." temp.o
cp temp.o nvnet.o
rm temp.o

and installed it:
# make install
mkdir -p //lib/modules/2.4.23/kernel/drivers/net
install -b -m 644 nvnet.o //lib/modules/2.4.23/kernel/drivers/net

but

# modprobe nvnet

produces

Warning: loading /lib/modules/2.4.23/kernel/drivers/net/nvnet.o will taint the kernel: non-GPL license - NVIDIA
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
/lib/modules/2.4.23/kernel/drivers/net/nvnet.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.23/kernel/drivers/net/nvnet.o: insmod /lib/modules/2.4.23/kernel/drivers/net/nvnet.o failed

twice.
any suggestions?
i use gcc 3.3.3 , libtool 1.5.2, modutils 2.4.26, kernel 2.4.23.



---------edit
heh the solution was simple:
i forgot to activate the nic in the bios...
__________________
Sorcerer:
http://Sorcerer.wox.org

Last edited by braindancer; 02-29-04 at 01:53 PM.
braindancer is offline   Reply With Quote