View Single Post
Old 10-14-02, 06:15 PM   #6
ltgnome
Registered User
 
Join Date: Oct 2002
Location: germany
Posts: 4
Thumbs up It works!


Oh yeah! 7 hours running system without freezing!

And here is the How to Do, at least in this (that means: my) case:

First some remarks:

When scanning the threads for the "freezing screen"-error I notized that in most cases the graphic-card was a GeForce2. Perhaps there is a general problem with this one, because the problem appears with different processors and different boards.

OK. Now let's take a look at the system:
GeForce2 GTS, Pentium III with 1000 MHz (ASUS), 1024 MB SDRAM (that means: at least enough of memory).
SuSE 8.1

Standard installation of SuSE8.1 Linux will install the "dummy"-nVIDIA-drivers. After install or update, test the functions of the X-windows-system with 'startx', 'startx gnome' or whatever you prefer. If it works well, you may install the (original) nVIDIA drivers. If you have installed the standard SuSE-kernel and all the other stuff you need from the distribution CDs/DVD without (too much) modifications, you may download the rpm-packages from the nvidia-donwload-page.
For SuSE8.1 there are the two rpm's:
- NVIDIA_kernel-1.0-3123.suse81.i586.rpm
and
- NVIDIA_GLX-1.0-3123.suse81.i586.rpm
and the README as text or pdf-file. Please read the instructions in this README if you have problems (it's really helpfull!).
After downloading the rpm's and reading the instructions, leave the X-window-system. Log in as root if you didn't yet.

Then uninstall the dummy-drivers with

rpm -e NVIDIA_kernel
rpm -e NVIDIA_GLX

(I don't know, if it's really necessary, but I think it's a good idea).

Edit (e.g. with vi) the XFree86-configuration-file. You will find it in the case of SuSE8.1 in the directory '/etc/X11' and it's named 'XF86Config' (resp. 'XF86Config-4'). Look for the line 'Section "Device"' It should look similar to the following lines:

Section "Device"
BoardName "GeForce2 GTS"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection

The actual data may vary a little bit, depending on your specific system. Add the following line in that section (that means between the 'Section' and the 'EndSection':

Option "NvAgp" "0"

Now it should look like this:

Section "Device"
BoardName "GeForce2 GTS"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
Option "NvAgp" "0"
EndSection

Install the drivers with the following commands (assuming you have changed to the directory where you stored the packages):

rpm -ivh NVIDIA_kernel-1.0-3123.suse81.i586.rpm
rpm -ivh NVIDIA_GLX-1.0-3123.suse81.i586.rpm
ldconfig

That's it. If you have a 'normal' running, not too much modified SuSE8.1-system, there should be no warnings or errors. In all other cases you have a problem with the system itself (see also README!).

After installing the packages I stopped the system (init 0) in order to be shure, to start a clean system.

And it worked for seven hours without any problem. "Normally" the freezing-problem occured after ten minutes or so. Best method was to use OpenOffice.org, changing the font of some text, calling the help-function - frozen...

I hope it will work in the other cases, too.
But I don't think, that this is the best way - it's not really a good idea to disable the AGP-features in order to have a running system... Perhaps someone has an idea what the reason for this behaviour is and perhaps there exists a workaround with less radical methods...

Good luck!

Last edited by ltgnome; 10-15-02 at 12:54 PM.
ltgnome is offline   Reply With Quote