View Single Post
Old 10-15-02, 02:25 AM   #2
Vancouverite
Guest
 
Posts: n/a
Default

I have almost the same hardware as you. A GeForce2 MX 400 and an NEC XV15 Multisync. It's working famously using 1024x768@80Hz with a custom modeline. First verify the configuration file XFree86 is using. This probably is /etc/X11/XF86Config-4 or /etc/X11/XF86Config.
Then set the the default depth and your modes to your preferences. I've included my own configuration file for you to reference. There is also plenty of howto's around for all of this.

/etc/X11/XF86Config:

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen "Screen"
InputDevice "Mouse" "CorePointer"
InputDevice "Keyboard" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "extmod"
Load "xie"
Load "pex5"
Load "dbe"
Load "record"
Load "xtrap"
Load "glx"
Load "speedo"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "Protocol" "Mouseman"
Option "Device" "/dev/ttyS0"
EndSection

Section "Device"
Identifier "nVidia GeForce2 MX400"
Driver "nvidia"
Option "ConnectedMonitor" "CRT"
Option "IgnoreEDID"
Option "NoLogo"
Option "DigitalVibrance" "1"
VideoRam 65536
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Monitor"
VendorName "NEC"
ModelName "XV15"
HorizSync 31 - 65
VertRefresh 55 - 100
Option "DPMS"
ModeLine "1024x768" 91.01 1024 1072 1312 1408 768 770 782 808 +hsync +vsync
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen"
Device "nVidia GeForce2 MX400"
Monitor "Monitor"
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection
  Reply With Quote